Compatiblity issues between Kaspersky Endpoint Security 10 for Windows and Ncomputing software

 

Kaspersky Endpoint Security 10 for Windows (for workstations and file servers)

 
 
 

Compatiblity issues between Kaspersky Endpoint Security 10 for Windows and Ncomputing software

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2018 Nov 21 ID: 13146
 
 
 
 

Description

When installing Kaspersky Endpoint Security 10 for Windows on a host with NComputing software (OfficeStar) installed, the operating system may return a fatal system error.

 

Cause

NComputing and the Kaspersky Endpoint Security 10 for Windows drivers may address the same win32k.sys function (ZwHookUserCallOneParam) at the same time.

 

Solution

To fix the problem, you can try disabling the Kaspersky Endpoint Security 10 for Windows driver which interacts with the win32k.sys function (ZwHookUserCallOneParam):

Perform the following actions on a clean system:

  1. Install Kaspersky Endpoint Security 10 for Windows.
  2. Reboot the computer.
  3. Disable Kaspersky Endpoint Security 10 for Windows Self-Defense.
  4. Download klif_shadowpatch.zip and extract its content into a folder.
It is highly recommended that you make a backup copy of the registry before making any changes to it.
  1. Run klif_shadowpatch.reg, and click Yes when prompted to confirm the changes.

This will create a ShadowPatchDisabled=1 dword value in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\KLIF\Parameters.

  1. Reboot the computer.
  2. Install NComputing software.
 
 
 
 
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