Problem beim Upgrade des Programms Kaspersky Security for Virtualization Light Agent unter Anwendung der Citrix App Layering und des vollständigen Benutzerlayers

 

Kaspersky Security for Virtualization 5.x Light Agent

 
 
 

Problem beim Upgrade des Programms Kaspersky Security for Virtualization Light Agent unter Anwendung der Citrix App Layering und des vollständigen Benutzerlayers

Zurück zu "Problembehandlung"
Zuletzt aktualisiert: 3. Juni 2021 Artikel ID: 15611
 
 
 
 
Der Artikel bezieht sich auf Kaspersky Security for Virtualization 5.1 Light Agent.
 
 
 
 

Problem

Bei Upgrade des Programms Kaspersky Security for Virtualization Light Agent, die zusammen mit der Citrix App Layering und dem vollständigen Benutzerlayer verwendet wird, auf die Version 5.1 können Ordner, Dateien und Registrierungsschlüssel der vorherigen Programmversion auf dem Computer erhalten bleiben.

Ursache

Die Empfehlungen von Citrix zur Installation eines Antivirenprogramms auf der Vorlage unter Anwendung des vollständigen Benutzerlayers wurden nicht befolgt. Dieser Layer speichert alle Änderungen an der virtuellen Maschine, die im Moment vorgenommen werden.

Lösung

  1. Die Vorlage mit der neuen Programmversion muss den mehrzeiligen Parameter AlwaysOnBoot im folgenden Registrierungsschlüssel enthalten: HKLM\SYSTEM\CurrentControlSet\Services\unifltr\. Als Schlüsselparameter fügen Sie die folgenden Ordner hinzu:
    • C:\ProgramData\KasperskyLab\
    • C:\ProgramData\Kaspersky Lab\
    • C:\Program Files(x86)\Kaspersky Lab\
    Dieser Schlüssel muss auf dem Layer sein, auf dem der Administrationsagent KLNagent und Kaspersky Security for Virtualization Light Agent installiert sind. Die verwendung des Schlüssels „AlwaysOnBoot“ ist eine umgehende Lösung von Citrix, die offiziell weder getestet noch unterstützt wird.
  2. Stellen Sie die Benutzerlayer anhand der Anleitungen in der Dokumentation von Citrix wieder her.

Detaillierte Empfehlungen zur Installation von Antivirenprogrammen finden Sie auch in der Dokumentation von Citrix.

 
 
 
 
Waren diese Informationen hilfreich?
Ja Nein
Danke
 

 
 

Wie können wir den Artikel verbessern?

Wir nutzen Ihr Feedback, nur um diesen Artikel zu verbessern. Wenn Sie Hilfe für unsere Produkte brauchen, wenden Sie sich an den technischen Support von Kaspersky.

Senden Senden

Danke für Ihr Feedback!

Ihre Vorschläge helfen uns dabei, den Artikel zu verbessern.

OK