"Certificate verification problem detected" and "Cannot guarantee authenticity of the domain to which encrypted connection is established" messages in Kaspersky Free

 

Kaspersky Free

 
 
 
 

"Certificate verification problem detected" and "Cannot guarantee authenticity of the domain to which encrypted connection is established" messages in Kaspersky Free

Back to "Troubleshooting"
Latest update: March 02, 2020 ID: 14584
 
 
 
 

Issue

When opening a website, a message appears stating that "Certificate verification problem detected" or "Authenticity of the domain to which encrypted connection is established cannot be guaranteed".

Cause

The website may not be safe. There is a possibility that intruders may steal your account data and other personal information. We do not recommend visiting such websites. 

For detailed information about what can cause the message to appear, see the section below.

Solution

If you are sure the website is safe, click I understand all risks and want to continue or Continue to proceed to the website.

"Cannot guarantee authenticity of the domain to which encrypted connection is established" message

"Cannot guarantee authenticity of the domain to which encrypted connection is established" message

If you want for the application to stop checking the website and showing warning messages, add the website to the list of exclusions:

  1. In the application main window, click The settings button in the lower-left corner.
  2. Go to the Additional section and select Network.
  3. Click Manage exclusions → Add.
  4. Specify the website address from the "Certificate verification problem" message. Select Active in the status field and then click Add.

The website will be excluded from the scanning list.

 
 
 
 
 

Why does the warning message appear

 
 
 
 
 

What to do if the message keeps reappearing

 
 
 
 
Was this information helpful?
Yes No
Thank you
 

 
 

How can we improve this article?

Your feedback will be used for content improvement purposes only. If you need assistance, please contact technical support.

Submit Submit

Thank you for your feedback!

Your suggestions will help improve this article.

OK