A Kaspersky application blocks access to the webcam for trusted applications

Latest update: November 09, 2023 ID: 15545
 
 
 
 
Show applications and versions that this article concerns
  • Kaspersky Security Cloud
  • Kaspersky Internet Security
  • Kaspersky Anti-Virus
  • Kaspersky Total Security
 
 
 
 

Issue

A Kaspersky application blocks access to the webcam for applications that have been included in the group of trusted and have all the permissions.

Cause

The application inherits the rules from the parent application that launched it.

For example, you have disabled access to the webcam for your browser. If you join a Zoom conference via a browser link, the webcam will not work because Zoom inherits the rules for your browser.

Solution

  1. Check that the application has access to the webcam.
  2. In the main window of a Kaspersky application, click More Tools.

Opening the tools of a Kaspersky application.

  1. Go to the Manage applications section and select Application Control.

Opening the Application Control window in a Kaspersky application.

  1. Click Manage applications.

Opening the Manage applications window in a Kaspersky application.

  1. Enter the application name in the search field.

Searching for the required app in a Kaspersky application.

  1. Right-click the app name and select Details and rules.

Managing the required app in a Kaspersky application.

  1. Select the Exclusions tab.
  2. Select the Do not inherit restrictions from the (application’s) parent process checkbox.
  3. Click Save.

Configuring the selected app in a Kaspersky application.

  1. Click Yes in the confirmation window.

The confirmation window in a Kaspersky application.

What to do if the issue persists

If the issue persists, contact Kaspersky Customer Service.

 
 
 
 
 
Did you find this article helpful?
What can we do better?
Thank you for your feedback! You're helping us improve.
Thank you for your feedback! You're helping us improve.