Issue displaying the Network icon in the taskbar when Kaspersky Endpoint Security 10 is running
Latest update: October 14, 2019
ID: 13628
This article concerns Kaspersky Endpoint Security 10 for Windows:
- Service Pack 2 Maintenance Release 4 (version 10.3.3.304)
- Service Pack 2 Maintenance Release 3 (version 10.3.3.275)
- Service Pack 2 Maintenance Release 2 (version 10.3.0.6294)
- Service Pack 2 Maintenance Release 1 (version 10.3.0.6294)
- Service Pack 2 (version 10.3.0.6294)
- Service Pack 1 Maintenance Release 4 (version 10.2.6.3733)
Description
The computer is connected and has access to the Internet, but the Network icon in the taskbar shows the warning sign and says No Internet access .
Cause
Kaspersky Endpoint Security 10 can block URLs that are used for checking Internet access.
Solution
- Open Kaspersky Security Center 10.
- Go to Policies and open the properties for the Kaspersky Endpoint Security 10 for Windows policy.
- Go to Web Anti-Virus and click Settings.
- Add the following URLs to the Trusted URLs lists:
- dns.msftncsi.com
- http://www.msftncsi.com/*
- Click OK.

If the issue persists
- Open Kaspersky Security Center 10.
- Go to Policies node and open the properties for the Kaspersky Endpoint Security 10 for Windows policy.
- Go to General Protection Settings. In the Exclusions and trusted zone section, click Settings.
- Open the Trusted applications tab and click Add.
- Exclude the file C:\Windows\System32\Svchost.exe from scanning.
- Select the checkbox Do not scan network traffic and specify port 80.
- Click OK.