Issue with multiple entries about Network Agent PDK patches in Kaspersky Security Center
The article concerns:
- Kaspersky Security Center 13 (version 13.0.0.11247)
- Kaspersky Security Center 12 (version 12.0.0.7734)
Issue
The database and the list of patch names are filled with similar entries about PDK patches for Network Agent.
Cause
Kaspersky Security Center generates patches on each device with the Network Agent installed instead of the single PDK patch for Network Agent. These patches only differ in their IDs.
For more information about the PDK patch, see below.
Solution
- Download the archive with the klsql2 tool.
- Extract the contents from the archive to any folder on a computer with the Administration Server installed.
- Open the src.sql file using a text editor.
- Copy a SQL request into the file for:
- Run the start.cmd file as administrator using the account used for installation of the Administration Server.
The results will be saved in the result.xml file. Old entries about PDK patches will be deleted and new entries will not be added.
What is a PDK patch
PDK patches are generated from libraries downloaded along with the antivirus databases. They are used for updating the library version in Kaspersky Security Center. For example, two PDK patches are formed for the OpenSSL library: one for Network Agent and the other for Administration Server.
To install the PDK patch for Administration Server, approve it in the Administration Console:
For Network Agent, the PDK patch is installed automatically and appears in the list for information.