Kaspersky Unified Monitoring and Analysis Platform
 
 

Troubleshooting frequent problems with All-in-One installation of Kaspersky Unified Monitoring and Analysis Platform

Latest update: March 13, 2024 ID: 16031
 
 
 
 
This article concerns Kaspersky Unified Monitoring and Analysis Platform 3.0.2.
 
 
 
 

Issue

After successful installation of Kaspersky Unified Monitoring and Analysis Platform (KUMA), you may encounter some errors:

Console with the message that the KUMA installation is successfully complete.

  • Pre-installed services have the red status and cannot be launched.

The error message in the KUMA interface.

  • When trying to download the pre-installed service logs, an error message appears informing you that the KUMA server name has not been specified.

The error message in the KUMA interface.

  • The error “failed to verify certificate: x509: certificate is valid for kuma, not kuma.demo” appears in the KUMA service log (collector, correlator, storage).

Cause

The errors occur because the server name specified in single.inventory.yml does not match the server name displayed when running the hostname -f command.

Solution

Follow the step-by-step instructions below. Run the specified commands using the sudo service.

 
 
 
 

Step 1. Check and change the server name

 
 
 
 

Step 2. Update certificates for the correct server name

 
 
 
 

Step 3. Recreate the services for the correct certificates

 
 
 
 
If the article didn’t help or you still have questions, create a topic on the Forum.
 
 
 
 
 
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