Known limitations of compatibility and migration for lists of trusted devices of the Device Control component in Kaspersky Endpoint Security 11 for Windows

 

Kaspersky Endpoint Security 11 for Windows

 
 
 

Known limitations of compatibility and migration for lists of trusted devices of the Device Control component in Kaspersky Endpoint Security 11 for Windows

Back to "Troubleshooting"
Latest update: October 27, 2020 ID: 15564
 
 
 
 

This article concerns: 

  • Kaspersky Endpoint Security 11.4.0 for Windows (version 11.4.0.233)
  • Kaspersky Endpoint Security 11.3.0 for Windows (version 11.3.0.773)
  • Kaspersky Endpoint Security 11.2.0 for Windows (version 11.2.0.2254)
  • Kaspersky Endpoint Security 11.1.1 for Windows (version 11.1.1.126)
  • Kaspersky Endpoint Security 11.1.0 for Windows (version 11.1.0.15919)
  • Kaspersky Endpoint Security 11.0.1 for Windows (version 11.0.1.90)
  • Kaspersky Endpoint Security 11.0.0 for Windows (version 11.0.0.6499)
 
 
 
 

When working with the list of trusted devices of the Device Control component, consider the following limitations:

  • The policies created with the help of administration plug-ins of Kaspersky Endpoint Security for Windows versions 11.0.0–11.2.0 do not support working with the list of trusted devices of the Device Control component in versions 11.3.0 and 11.4.0. To work with the trusted devices in versions 11.3.0 and 11.4.0, upgrade the administration plug-in to version 11.3.0 or 11.4.0.
When you open a policy file after installing the plug-in version 11.4.0, the policy is automatically updated. To roll back to the previous version, you will have to delete the policy file and the plug-in. We recommend that you create a backup copy of a server and policies before upgrading the administration plug-in.
  • The administration plug-in of Kaspersky Endpoint Security for Windows versions 11.3.0 and 11.4.0 does not support working with the list of trusted devices of the Device Control component in versions 11.2.0 and earlier. For correct work with the list of trusted devices, upgrade the application to version 11.3.0 or 11.4.0.
  • Kaspersky Endpoint Security for Windows version 11.4.0 administration plug-in automatically converts the rules from version 11.2.0 to the new format. If your infrastructure is not ready for migration to version 11.4.0 in full but the rules have already been converted and some computers in the network have version 11.4.0 installed, the policy can be adjusted for correct processing of the rules of both versions. In this case, send a request to technical support with a detailed description of your issue via CompanyAccount. Attach the policy file that required adjustment to your request.

If it is not possible to migrate Kaspersky Endpoint Security for Windows to 11.3.0 or 11.4.0 installed on hosts in short time, do the following:

  • Before upgrading the Kaspersky Endpoint Security for Windows administration plug-in, export the policies to a file. If you have already updated the plug-in, export the policies before saving any plug-in settings.
  • If a policy in version 11.0.0–11.2.0 had device control rules set according to device ID mask, install the plugin version 11.3.0.840 or 11.4.0.289. These versions partially support Kaspersky Endpoint Security for Windows version 11.0.0–11.2.0. This is implemented by replacing each rule with two new rules: for versions 11.0.0–11.2.0 and for versions 11.3.0 and later.
 
 
 
 
Was this information helpful?
Yes No
Thank you
 

 
 

How can we improve this article?

Your feedback will be used for content improvement purposes only. If you need assistance, please contact technical support.

Submit Submit

Thank you for your feedback!

Your suggestions will help improve this article.

OK