Error upgrading Kaspersky Endpoint Security for Windows to version 11.10.0 and above
Show applications and versions that this article concerns
- Kaspersky Endpoint Security 12.2.0 for Windows (version 12.2.0.462)
- Kaspersky Endpoint Security 12.1.0 for Windows (version 12.1.0.506)
- Kaspersky Endpoint Security 12.0.0 for Windows (version 12.0.0.465)
- Kaspersky Endpoint Security 11.11.0 for Windows (version 11.11.0.452)
- Kaspersky Endpoint Security 11.10.0 for Windows (version 11.10.0.399)
Issue
When upgrading Kaspersky Endpoint Security for Windows to version 11.10.0 or above, you may encounter the error “The incompatible klhk driver was detected in the previous application version. Please update the anti-virus databases and retry the upgrade. For more details, see https://support.kaspersky.com/15905».
Cause
Kaspersky Endpoint Security for Windows databases are out of date.
Solution
- Run the database update task in the installed version of Kaspersky Endpoint Security for Windows.
- Make sure the database release date matches (or is newer than) the update release date. Otherwise, check if the database update task was successful.
If you are using an update source other than a Kaspersky server, e.g. Kaspersky Security Center, or a source created via Kaspersky Update Utility, check whether the application configuration is correct.
- Upgrade the application once again if the database update has been successful.
What to do if the issue persists
If the issue persists, use these tips and submit a request to Kaspersky Technical Support via Kaspersky CompanyAccount. Attach an archive with the following:
- A GSI report from the machine on which the update error was registered with the Windows event log enabled.
- A screenshot of the update error or the update task history export and the update task file.
- The export of the update task report if the task has been created and started in Kaspersky Endpoint Security for Windows.