‘Cant exec “/opt/kaspersky/klms/libexec/generate_uuid"’ error

 

Kaspersky Security 8.0 for Linux Mail Server

 
 
 

‘Cant exec “/opt/kaspersky/klms/libexec/generate_uuid"’ error

Back to "Installation /Uninstallation"
Latest update: 2019 Jul 15 ID: 9906
 
 
 
 
The article concerns Kaspersky Security 8.0 for Linux Mail Server Maintenance Pack 3 (version 8.0.3.30).
 
 
 
 

When installing Kaspersky Security 8.0 for Linux Mail Server on a 64-bit Linux distribution, you might get the following error: ‘Cant exec "/opt/kaspersky/klms/libexec/generate_uuid": No such file or directory at /opt/kaspersky/klms/lib/perl/KL/App.pm line 2172, <STDIN> line 6. Error: FATAL: cant generate installation id’.

Cause

The 32-bit compatibility libraries are not installed.

Solution

Install the packages for your distribution:

  • For Debian and Ubuntu:
    • lib32z1
    • lib32ncurses5
  • For RHEL and CentOS — yum install glibc.i686
  • For OpenSuSE, SLES and OES — zypper install glibc-32bit
 
 
 
 
Was this information helpful?
Yes No
Thank you
 

 
 

How can we improve this article?

Your feedback will be used for content improvement purposes only. If you need assistance, please contact technical support.

Submit Submit

Thank you for your feedback!

Your suggestions will help improve this article.

OK