Network connection error. DNS issue
Latest update: July 19, 2024
ID: 13771
Cause
- Incorrect date set on a computer.
- DNS client service does not work on your computer.
- DNS server malfunction on your Internet services provider’s side.
Solution
- Check the system date on your computer. See this article for instructions.
- Make sure that DNS client service works correctly. If the service is not running, restart it. See the guide below.
- If the DNS client service is working, but the issue persists, try entering the address of a different DNS server in the network settings. See the guide below.
How to restart the DNS client
- Press and hold the and R keys on your keyboard.
- In the Run window, type services.msc and click OK.
- In the Services window, check if DNS Client has started.
- If the service is not running, restart it. To do so, right-click on in the list and select Restart from the shortcut menu.
DNS client service has been restarted.
How to change the DNS address in the network settings
- Press and hold the and R keys on your keyboard.
- In the Run window, type ncpa.cpl and click OK.
- In the Network Connections window, right-click the required network connection and select Properties.
- In the Networking tab, select Internet Protocol Version 4 (TCP/IPv4) and click Properties.
- In the Properties window: For Internet Protocol Version 4 (TCP/IPv4), select Use the following DNS server addresses and enter:
- Preferred DNS server: 8.8.8.8
- Alternate DNS server: 8.8.4.4
- Click OK.
- In the Ethernet: properties window, click OK.
DNS server address will be added to the network properties.
What to do if the issue persists
If the issue persists, submit a request to Kaspersky Customer Service by choosing the topic and filling out the form.
Customer support for Kaspersky Free is not provided. You can ask a question about your issue on our Forum or look it up in the existing topics.