How to remove viruses from your computer before installing a Kaspersky application
This article concerns:
- Kaspersky Basic, Standard, Plus, Premium
- Kaspersky Security Cloud
- Kaspersky Internet Security
- Kaspersky Anti-Virus
- Kaspersky Total Security
- Kaspersky Small Office Security
- Kaspersky Free
- Installation does not start. Nothing happens when you run the installer.
- Errors occur during installation:
- Error 1304.
- Active infection: Failed to install a Kaspersky application. Your computer might be infected. For information, see this article.
- The application was not installed. Your computer may be infected by viruses. For details, see this article.
Causes
- Your computer is currently infected with malware which prevents the installation.
- Another antivirus solution is installed on your computer.
- There are files of earlier Kaspersky application versions remaining on your computer.
Solution
- Scan your computer for viruses using:
- Kaspersky Virus Removal Tool. For instructions, see this article.
- Kaspersky Rescue Disk. For instructions, see this article.
- Uninstall an incompatible antivirus solution and try installing a Kaspersky application once again. See the guide below.
- Delete the remaining files of earlier versions of the application. See the guide below.
If one of the solutions above helped, after successful installation of a Kaspersky application run a full virus scan. See the guide below.
If the issue persists, contact Kaspersky Customer Service. See the guide below.
How to uninstall an incompatible antivirus solution
Find the antivirus application and uninstall it from your computer.
To uninstall the application from Windows PC:
- Open Control Panel. See the instructions on the Microsoft support website.
- Go to Programs → Programs and Features.
- Find the application in the list and click Uninstall/Change.
- Follow the instructions of the Wizard.
To uninstall the application from Mac:
- Open Finder and go to the Applications tab.
- Find the application icon.
- Drag-and-drop it to Trash.
- Restart your Mac.
Try to install the Kaspersky application once again.
If you have problems removing the application or the issue persists after successful uninstallation, use the guide for removing a third-party antivirus software.
What to do if you can't update your Kaspersky application to the latest version
When switching to a new version of the Kaspersky application, you may get the error "The application was not installed. Your computer may be infected by viruses."
Should this error occur, remove the Kaspersky application using the kavremover tool and reinstall it on your computer. See this article for instructions.
Recommendations after successful installation
Kaspersky applications use the Advanced Disinfection technology for eliminating active infections. This feature fights against malicious programs that are running on the computer and preventing anti-virus software from removing them.
If such malicious code is detected, the Advanced Disinfection technology does the following:
- Blocks the launch of any new processes in the system.
- Blocks any startup-related changes to the System Registry.
- Blocks the creation of new files in startup folders.
- Blocks the creation of new executable files.
- Runs a scan of startup objects and removes the malicious code.
- Restarts the computer.
- Starts the system without the malicious code.
Upon restart, run a full virus scan. See instructions in Online Help for your Kaspersky application:
- Kaspersky Basic, Standard, Plus, Premium
- Kaspersky Security Cloud
- Kaspersky Internet Security
- Kaspersky Anti-Virus
- Kaspersky Total Security
- Kaspersky Small Office Security
- Kaspersky Free
To enable the Advanced Disinfection technology:
- In the main window, click . To learn how to open the main application window, see this article.
- If you are using:
- Kaspersky Basic, Standard, Plus or Premium, go to Performance settings → PC resource consumption and make sure the checkbox Use Advanced Disinfection technology is selected.
- Kaspersky Security Cloud, Kaspersky Internet Security, Kaspersky Anti-Virus, Kaspersky Total Security, Kaspersky Small Office Security or Kaspersky Free, go to the General section and make sure that the Use Advanced Disinfection technology.
Advanced Disinfection technology will be enabled.
What to do the issue persists
The the above recommendations did not help and Kaspersky Rescue Disk and Kaspersky Virus Removal Tool detected no threats, contact Kaspersky Customer Service by choosing the topic and filling out the form.
In your request, please provide the following:
- Registration data (date and place of purchase, customer name, activation code).
- Screenshot of the error message
- Kaspersky Get System Info tool report.
Customer Service for Kaspersky Free is not provided. You can ask a question about your issue on our Forum or look it up in the existing topics.
If you want full support, buy and install a supported Kaspersky application for home.