Upgrading automatically on Linux

February 27, 2024

ID 184791

This section describes how to upgrade Kaspersky CyberTrace on Linux to version 4.3.

You can upgrade Kaspersky CyberTrace to version 4.3 only from version 4.2.

The instruction below applies to the RPM/DEB package installations.

To upgrade Kaspersky CyberTrace automatically to a newer version:

  1. Run the following command with root privileges:

    run.sh upgrade

  2. At the beginning of the upgrade process, accept the request to stop Kaspersky CyberTrace Service. If you decline to stop it, the upgrade fails.

    At the end of the upgrade process, all the settings, user accounts data, available feeds, and certificates will be automatically transferred to the new version.

    After the upgrade process is finished, the actionable fields are not specified for new feeds that were not supported in the previous version. If needed, specify these fields manually on the Settings > Feeds tab.

    When upgrading from previous versions, make sure that /opt/kaspersky/ktfs/etc/kl_feed_service.conf contains only a single copy of the FalsePositive and InternalTI suppliers, with the corresponding standard names (Black_List.json and White_List.json). If not, the script displays an error and exits.

    After you finish the upgrade process, Kaspersky CyberTrace Service will be launched automatically.

If upgrade to a newer version fails, Kaspersky CyberTrace rolls back to the version that was operable at the time of upgrade start.

Note that the automatic upgrade functionality is available only if you have accepted the EULA in the installation that is being upgraded.

Actions in case of error during upgrade

The configuration files and some other files are moved to the /opt/kaspersky_cybertrace_tmp temporary directory during the upgrade after Kaspersky CyberTrace Service stops. If errors occur during the upgrade, the moved files remain in the temporary directory.

The upgrade log file is located in the /temp directory or in the directory specified in the $TEMP environment variable, if $TEMP is defined.

If you encountered an error during an automatic upgrade, contact your Technical Account Manager (TAM) for more information on solutions to the problem.

Did you find this article helpful?
What can we do better?
Thank you for your feedback! You're helping us improve.
Thank you for your feedback! You're helping us improve.