Probleme mit der Verbindung zwischen dem Administrationsagenten für Windows und dem Administrationsserver

Zuletzt aktualisiert: 16. Februar 2024 Artikel ID: 12776
 
 
 
 
Der Artikel bezieht sich auf folgende Anwendungsversionen:
  • Kaspersky Security Center 14.2 (Version 14.2.0.26967)
  • Kaspersky Security Center 14 (Version 14.0.0.10902)
  • Kaspersky Security Center 13.2 (Version 13.2.0.1511)
  • Kaspersky Security Center 13.1 (Version 13.1.0.8324)
  • Kaspersky Security Center 13 (Version 13.0.0.11247)
 
 
 
 

Problem

  • Die Remote-Installation des Administrationsagenten wurde erfolgreich abgeschlossen, aber das verwaltete Remote-Gerät wird auf dem Administrationsserver jedoch nicht angezeigt. Oder das Objekt ist zwar vorhanden, aber es fehlt die Markierung, dass der Administrationsagent darauf installiert ist.
  • Gleichzeitige Remote-Installation des Administrationsagenten und des Antivirenprogramms wird bis zu 50 Prozent ausgeführt und dann gestoppt, wobei die Meldung angezeigt wird, dass der Administrationsagent erfolgreich installiert wurde. Das Ereignisprotokoll in der Verwaltungskonsole ergibt, dass das Antivirenprogramm nicht installiert wird.
  • Die Verbindung zum verwalteten Gerät wurde nach der Installation der neuesten Version des Administrationsagenten über die vorherige Version abgebrochen. In der Aufgabe wird die Meldung angezeigt, dass das verwaltete Gerät neu gestartet werden muss.
  • Die Prüfung der Verbindung des Administrationsagenten zum Administrationsserver mithilfe des Tools klnagchk.exe wird mit einem Fehler abgeschlossen.
  • Die Remote-Installation des Administrationsagenten hängt mit dem Status „Wird ausgeführt (32%) (Gerät nicht verfügbar)“ oder „Auf dem gerät wurde der Installationsdienst gestartet. Bitte, warten Sie...“.
    Dabei wird der Dienst des Administrationsservers auf dem Zielgerät nicht ausgeführt und der Start einer beliebigen Komponente verursacht folgendes:
    • Im Anwendungsverlauf von Windows wird ein Eintrag über die Dateien emcat.dl und em.dll angezeigt: „Information 1603. Die Datei C:\Program Files (x86)\Kaspersky Lab\NetworkAgent\em.dll wird verwendet. Schließen Sie das Programm und versuchen Sie es erneut“.
    • Der Administrationsagent wird unerwartet mit dem folgenden Fehler beendet: „Name der fehlerhaften Anwendung: klnagent.exe, Version: 14.2.0.26967, Zeitstempel: 0xa0f42d48 Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.1.7601.17514, Zeitstempel 0x4ce7bafa <...>“.

Ursache

  • In den Eigenschaften des Installationspakets oder der Richtlinie für den Administrationsagenten werden inkorrekte Einstellungen verwendet.
  • Es ist ein Fehler des Dienstes des Administrationsagenten (klnagent) aufgetreten.
  • Die Dateien des Administrationsagent sind durch dritte Software blockiert.
  • Es kann keine Verbindung zwischen dem Administrationsagenten und dem Administrationsserver aufgebaut werden.

Lösung

Die oben aufgeführten Probleme können anhand mehrerer Methoden behoben werden. Die ersten zwei Methoden zur Problembehandlung werden auf dem Administrationsserver verwendet, weitere Methoden werden auf den verwalteten Geräten verwendet.

 
 
 
 

Lösung 1. Führen Sie eine Suche in nicht zugeordneten Geräten aus

 
 
 
 

Lösung 2. Prüfen Sie die Verbindungseinstellungen im Installationspaket des Administrationsagenten, der über eine Installationsaufgabe verteilt wird

 
 
 
 

Lösung 3. Prüfen Sie, dass das Update KB3063858 auf Geräten mit veralteten Betriebssystemen installiert ist

 
 
 
 

Lösung 4. Prüfen Sie, dass der Dienst des Administrationsagenten ausgeführt und seine Dateien nicht blockiert sind

 
 
 
 

Lösung 5. Prüfen Sie, dass der Administrationsagent vorher nicht installiert wurde

 
 
 
 

Lösung 6. Prüfen Sie, dass die Verbindung zum Administrationsserver auf dem Zielgerät aufgebaut werden kann

 
 
 
 

Vorgehensweise, wenn das Problem weiterhin besteht

 
 
 
 
 
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