Fehler 408 „Request Timeout“ in Kaspersky Scan Engine
Zuletzt aktualisiert: 7. Dezember 2020
Artikel ID: 15644
Fehler 408 „Request Timeout“ beim Senden von Anfragen mit einem Time-out
Ursache
- Wenn die Antwort vor dem Ablauf des in der Anfrage angegebenen Time-outs eintrifft und den Fehler „Session Timeout“ enthält, wird das Problem durch das Time-out der Sitzung auf der Seite von Kaspersky Scan Engine verursacht. Beispiel für eine Antwort:
HTTP/1.0 408 Request Timeout
Connection: close
Content-Type: text/plain
Server: KAVHTTPD/1.0
X-KAV-ProtocolVersion: 3
Date: Tue, 13 Oct 2020 09:43:07 GMT
Content-Length: 35
{
"error": "Session Timeout"
}
Connection: close
Content-Type: text/plain
Server: KAVHTTPD/1.0
X-KAV-ProtocolVersion: 3
Date: Tue, 13 Oct 2020 09:43:07 GMT
Content-Length: 35
{
"error": "Session Timeout"
}
- Wenn die Antwort nach Ablauf des in der Anfrage angebenen Time-outs eingegangen ist und den Fehler „scanResult“: „SERVER_ERROR“ enthält, wird wird das Problem durch das Time-out der Aufgabe zum Scannen verursacht. Beispiel für eine Antwort:
HTTP/1.0 408 Request Timeout
Connection: close
Content-Type: text/plain
Server: KAVHTTPD/1.0
X-KAV-ProtocolVersion: 3
Date: Tue, 13 Oct 2020 10:43:20 GMT
Content-Length: 97
{
"object": "Memory",
"scanResult": "SERVER_ERROR"
}
Connection: close
Content-Type: text/plain
Server: KAVHTTPD/1.0
X-KAV-ProtocolVersion: 3
Date: Tue, 13 Oct 2020 10:43:20 GMT
Content-Length: 97
{
"object": "Memory",
"scanResult": "SERVER_ERROR"
}
Lösung
- Um den Fehler „Session Timeout“ zu beheben, erhöhren Sie das Time-out der Sitzung. Dazu öffnen Sie die Konfigurationsdatei /etc/kavhttpd.xml und legen Sie einen größeren Wert für den Parameter „SessionTimeout“ fest. Darüber hinaus können Sie das Time-out der Sitzung über die Steuerungsleiste von Kaspersky Scan Engine erhöhen. Die Anleitung ist weiter unten.
- Um den Fehler „scanResult“: „SERVER_ERROR“ zu beheben, legen Sie ein größeres Time-out für die Aufgabe zum Scannen fest. Gehen Sie dazu wie folgt vor:
- Wenn Sie API v3.0 verwenden, legen Sie einen größeren Wert für den Parameter „timeout“ in der zu sendenden JSON-Struktur.
- Wenn Sie API v1.0 oder 2.0 verwenden, legen Sie einen größeren Wert in der HTTP-Kopfzeile „X-KAV-Timeout“ fest.
Fehler 408 „Request Timeout“ beim Scannen von Dateien
Beim Scannen kleinerer zusammengesetzter Dateien kann Kaspersky Scan Engine die Antwort mit dem Fehler 408 „Request Timeout“. Die Antwort kann den folgenden Fehler enthalten:
{
"object": "Memory", "scanResult": "SERVER_ERROR"
}
"object": "Memory", "scanResult": "SERVER_ERROR"
}
Oder den folgenden Fehler:
{
"error": "Session Timeout"
}
"error": "Session Timeout"
}
Der Fehler kann beim Scannen folgender Objekte auftreten:
- Archive
- eingepackte Laufwerk-Images
- Installationspakete im Format MSI, EXE oder APK
- Java-Dateien im Format JAR, EAR oder WAR
Ursache
Dieser Fehler wird dadurch verursacht, dass Dateien, obwohl sie auch nicht groß sind, zahlreiche untergeordnete Objekte enthalten können. Das Scannen dieser untergeordneten Objekte kann lange dauern.
Lösung
- Legen Sie ein größeres Time-out für die Sitzung fest. Dazu öffnen Sie die Konfigurationsdatei /etc/kavhttpd.xml und legen Sie einen größeren Wert für den Parameter „SessionTimeout“ fest. Darüber hinaus können Sie das Time-out der Sitzung über die Steuerungsleiste von Kaspersky Scan Engine erhöhen. Die Anleitung ist weiter unten.
- Legen Sie ein größeres Time-out für die Aufgabe zum Scannen fest. Gehen Sie dazu wie folgt vor:
- Wenn Sie API v3.0 verwenden, legen Sie einen größeren Wert für den Parameter „timeout“ in der zu sendenden JSON-Struktur.
- Wenn Sie API v1.0 oder 2.0 verwenden, legen Sie einen größeren Wert in der HTTP-Kopfzeile „X-KAV-Timeout“ fest.
So erhöhen Sie das Time-out für die Sitzung über die Webkonsole von Kaspersky Scan Engine
- Öffnen Sie die Webkonsole von Kaspersky Scan Engine und gehen Sie auf Settings → Scanning.
- Legen Sie ein Time-out in Millisekunden im Feld Object scan timeout (ms) fest.
Die in diesem Feld angegebene Zeit sollte ausreichen, um die Verbindung herzustellen, die Datei an Kaspersky Scan Engine weiterzuleiten, die Datei zu scannen und einen Bericht zu senden. Wir empfehlen einen relativ großen Wert anzugeben, damit die Zeit ausreicht, um die zu untersuchenden Dateien zu senden und zu scannen.
Das Time-out für die Sitzung wird erhöht.