Fehler mit dem Code „0x8000ffff“ bei der Installation der Treiber von Kaspersky Endpoint Security für Windows
Zuletzt aktualisiert: 9. August 2024
Artikel ID: 15565
Der Artikel bezieht sich auf folgende Anwendungsversionen:
- Kaspersky Endpoint Security 12.6 für Windows (Version 12.6.0.438)
- Kaspersky Endpoint Security 12.5 für Windows (Version 12.5.0.539)
- Kaspersky Endpoint Security 12.4 für Windows (Version 12.4.0.467)
- Kaspersky Endpoint Security 12.3 für Windows (Version 12.3.0.493)
- Kaspersky Endpoint Security 12.2 für Windows (Version 12.2.0.462)
- Kaspersky Endpoint Security 12.1 für Windows (Version 12.1.0.506)
- Kaspersky Endpoint Security 12.0 für Windows (Version 12.0.0.465)
- Kaspersky Endpoint Security 11.11 für Windows (Version 11.11.0.452)
- Kaspersky Endpoint Security 11.10 für Windows (Version 11.10.0.399)
- Kaspersky Endpoint Security 11.9 für Windows (Version 11.9.0.351)
- Kaspersky Endpoint Security 11.8 für Windows (Version 11.8.0.384)
- Kaspersky Endpoint Security 11.7 für Windows (Version 11.7.0.669)
Problem
Bei der Installation von Kaspersky Endpoint Security für Windows können Fehler im Schritt der Installation der Treiber auftreten.
Beispiele der Fehler:
-
InstallDriversDeferred: Failed to add a catalog file. Error 0x8000ffff.
***
MSI (s) (14!30) [11:07:22:451]: Product: Kaspersky Endpoint Security 10 for Windows – Error 27300.Error installing driver kl1.sys_X86. Error: -2147418113.
InstallDriversDeferred: InstallDriversDeferred: finished. Return value 1603. -
InstallDriversRollback (1b38:20b8) [15:46:19:896]: Failed to execute driver package 'mklif.sys_x64'. Failed to remove a catalog file. Error 0x8000ffff.
***
MSI (s) (60!E8) [15:46:19:688]: Programm: Kaspersky Endpoint Security für Windows – Fehler 27300. Fehler bei der Installation des Treibers mklif.sys_x64. Fehler: -2147418113.
Die Fehler werden im Installationsverlauf des Programms angezeigt.
Ursachen
Die Integrität des Betriebssystems ist beschädigt: Probleme mit dem Verschlüsselungsdienst, Speicher für Treiberverzeichnisse CryptoAPI (CAT) sowie mit der Überprüfung der Signaturen von Verzeichnissen.
Diagnose
Zur erweiterter Diagnose und Feststellung von Problemen mit dem Verschlüsselungsdienst können Sie folgende Aktionen ausführen:
- Überprüfen Sie das Systemverlauf „Application“ auf dem Gerät mit dem installierten Programm. Es kann Ereignisse des folgenden Typs enthalten: „The Cryptographic Services service failed to initialize the Catalog Database. The error was: -2147418113 (0x8000ffff) : Catastrophic failure.“
- Überprüfen Sie die Datei „%WINDIR%\System32\catroot2\dberr.txt“ auf Zeilen mit dem Fehler „encountered JET error -583“.
- Überprüfen Sie die Datei „%WINDIR%\INF\setupapi.dev.log“ auf Fehler mit dem Code „0x8000ffff“. z. B.: „Error 0x8000ffff: Catastrophic failure.“
Lösung
Wenn Sie die oben genannten Fehler gefunden haben, gehen Sie wie folgt vor:
- Beheben Sie das Problem mit dem Betriebssystem selbstständig oder wenden Sie sich an den Support von Microsoft.
- Versuchen Sie es erneut, das Programm zu installieren.