Kaspersky Endpoint Security 11 für Linux
 
 

Zugriffsfehler beim Speichern von Dokumenten in Netzwerkordnern, die auf dem CIFS-Protokoll basieren

Zuletzt aktualisiert: 15. Januar 2024 Artikel ID: 16014
 
 
 
 
Der Artikel bezieht sich auf folgende Anwendungsversionen:
  • Kaspersky Endpoint Security 12 für Linux (Version 12.0.0.6672)
  • Kaspersky Endpoint Security 11.4.0 für Linux (Version 11.4.0.1096)
  • Kaspersky Endpoint Security 11.3.0 für Linux (Version 11.3.0.7508)
  • Kaspersky Endpoint Security 11.3.0 für Linux (Version 11.3.0.7441)
  • Kaspersky Endpoint Security 11.2.0 für Linux (Version 11.2.0.4528)
 
 
 
 

Problem

Bei der Speicherung geänderter Dateien der Formate DOCX und XLSX können folgende Fehler in Office-Anwendungen und anderen Anwendungen, die Sperrdateien ähnlich nutzen, auftreten: „Zugriffsfehler“, „Ein Dokument konnte nicht gesperrt werden“ oder „Zugriff verweigert“.

Das Problem kann in folgenden Fällen auftreten:

  • Das geänderte Dokument befindet sich in einem Netzwerkordner.
  • Der Netzwerkordner ist mit dem CIFS-Protokoll montiert.
  • Der Mountpunkt ist vom Dateioperationen-Interceptor markiert und zu globalen Ausschlüssen nicht hinzugefügt.

Ursache

Der Fehler wird durch ein Problem der Interaktion des CIFS-Protokolls und der Fanotify-Technologie des Linux-Kernels zum Abfangen von Dateioperationen ausgelöst. Es liegt daran, dass das Betriebssystem nach erneuter Erstellung der temporären Datei den Fehler EPERM (errno 1 Operation not permitted) in der Benutzeranwendung auslöst.

Das Problem ist dem Entwickler des Betriebssystems bekannt und soll in Zukunft behoben werden.

Lösung

  • Kontaktieren Sie den technischen Supports für das Betriebssystem, wobei Sie auf dieses Problem hinweisen, und fordern Sie einen privaten Patch oder eine Kernel-Version an, die vom beschriebenen Problem der Interaktion von CIFS und fanotify nicht betroffen ist.
  • Fügen Sie den Mountpunkt zu globalen Ausschlüssen (Einstellung ExcludedMountPoint) lokal oder über die Richtlinie im Kaspersky Security Center hinzu, bis das Problem vom Entwickler des Betriebssystems behoben worden ist.
 
 
 
 

So fügen Sie einen Mountpunkt zu globalen Ausschlüssen hinzu

 
 
 
 

So fügen Sie einen Mountpunkt zu globalen Ausschlüssen über die Richtlinieneinstellungen im Kaspersky Security Center hinzu

 
 
 
 
 
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