Der Dienst „kladminserver“ wird nach dem Upgrade des Kaspersky Security Center nicht mehr gestartet
Problem
Nach dem Upgrade des Kaspersky Security Center auf die Version 13.2 wird der Dienst „kladminserver“ nicht gestartet, und im Ereignisverlauf wird die folgende Meldung angezeigt:
„Der Dienst 'kladminserver' wurde aufgrund eines Fehlers gestoppt. #1950 (102) Generic db error: "102 'Incorrect syntax near '('.{42000};' LastStatement='EXEC grp_sync_subgroups'"“.
Ursache
Das Problem wird durch einen falschen Parameter des Datenbankkompatibilitätsgrades im Microsoft SQL Server verursacht.
Lösung
Ändern Sie den Kompatibilitätsgrad der Datenbank im Microsoft SQL Server Management Studio durch die Eingabe des folgenden Befehls:
Wenn Sie Microsoft SQL Server Express Edition verwenden, laden Sie die kostenfreie Version von Microsoft SQL Server Management Studio herunter.
Geben Sie den Kompatibilitätsgrad je nach der verwendeten Version des Microsoft SQL Server an:
Version des Microsoft SQL Server | Kompatibilitätsgrad |
---|---|
2014 (12.x) | 120 |
2016 (13.x) | 130 |
2017 (14.x) | 140 |
2019 (15.x) | 150 |
Darüber hinaus können Sie den Kompatibilitätsgrad der Datenbank über die Benutzeroberfläche des SQL Management Studio ändern. Die Anleitung ist auf der Website von Microsoft.
Was tun, wenn die oben angeführte Lösung nicht geholfen hat
Wenn das Problem weiterhin besteht, senden Sie eine Anfrage an den technischen Support von Kaspersky via Kaspersky CompanyAccount. In der Wissensdatenbank finden Sie Informationen, die bei der Erstellung einer Anfrage an den Support hilfreich sind.