Konfigurieren des Betriebssystems zur Behebung von Fehlern bei einer Remote-Installation des Kaspersky Security Center Administrationsagenten
Der Artikel bezieht sich auf folgende Anwendungsversionen:
- Kaspersky Security Center 14.2 (Version 14.2.0.26967)
- Kaspersky Security Center 14 (Version 14.0.0.10902)
- Kaspersky Security Center 13.2 (Version 13.2.0.1511)
- Kaspersky Security Center 13.1 (Version 13.1.0.8324)
- Kaspersky Security Center 13 (Version 13.0.0.11247)
Diese Anweisungen gelten nicht direkt für Kaspersky-Anwendungen. Der technische Support zur Konfiguration wird im Rahmen der normalen Funktion des Betriebssystems gemäß der Dokumentation für diese Betriebssysteme geleistet.
Problem
Beim Versuch, die Aufgabe zur Remote-Installation des Administrationsagenten oder eines benutzerdefinierten Installationspakets mit dritter Software Unter Nutzung von Betriebssystemressourcen durch den Administrationsserver oder Unter Nutzung von Betriebssystemressourcen durch Verteilungspunkte auszuführen, können Fehler wegen inkorrekter Konfiguration des Zielgeräts auftreten.
Ursache
Fehler | Ursache |
---|---|
„Der freigegebene Ordner "\\192.0.2.45\admin$" steht für folgende Benutzerkonten nicht zur Verfügung: ˂Aktuelles Benutzerkonto für Dienst des Administrationsservers˃ (Zugriff verweigert)“. | Die Remote-Benutzerkontensteuerung ist aktiviert. |
„Der Verteilungspunkt "˂DP_name˃“ konnte die Remote-Installation nicht starten. Das Download des Installationspakets vom Administrationsserver in den freigegebenen Ordner auf dem Gerät wurde mit Fehler abgeschlossen: ˂Benutzerkonto des Dienstes des Kaspersky Security Center 14.2 Administrationsagenten> (Zugriff verweigert) Die Liste der Verteilungspunkte ist erschöpft.“ | |
„Der freigegebene Ordner "\\192.0.2.45\admin$" steht für folgende Benutzerkonten nicht zur Verfügung: Fehler 1181/0x43 ('System error 0x43 (Der Netzwerkname konnte nicht gefunden werden.)') beim Zugriff auf das Objekt des Dateisystems '\\192.0.2.45\admin$\Temp\KAV Remote Installations\17448b048259422d801bb86c01520348_1'“. | Es gibt keine freigegebenen Ordner. |
„Der Verteilungspunkt "˂DP_name˃“ konnte die Remote-Installation nicht starten. Das Download des Installationspakets vom Administrationsserver in den freigegebenen Ordner auf dem Gerät wurde mit Fehler abgeschlossen: Fehler 1181/0x43 ('System error 0x43 (Der Netzwerkname konnte nicht gefunden werden.)') beim Zugriff auf das Objekt des Dateisystems '\\192.0.2.45\admin$\Temp\KAV Remote Installations\12ea84896a6b4b679dfdaeb663cedd00_1'. Die Liste der Verteilungspunkte ist erschöpft“. | |
„Der freigegebene Ordner "\\192.0.2.45\admin$" steht für folgende Benutzerkonten nicht zur Verfügung: ˂Aktuelles Benutzerkonto für Dienst des Administrationsservers˃ (RPC-Server nicht verfügbar)“. |
|
„Der Verteilungspunkt "˂DP_name˃“ konnte die Remote-Installation nicht starten. „Das Download des Installationspakets vom Administrationsserver in den freigegebenen Ordner auf dem Gerät wurde mit Fehler abgeschlossen: ˂Benutzerkonto des Dienstes des Kaspersky Security Center 14.2 Administrationsagenten> (RPC-Server nicht verfügbar.) Die Liste der Verteilungspunkte ist erschöpft.“ | |
„Gerät ist möglicherweise vom Netzwerk getrennt“. | Der Dienst der Datei- und Drickerfreigabe ist deaktiviert. |
„RPC-Server nicht verfügbar“. | Die normale Funktion des Betriebssystems wurde gestört. |
Lösung
Remote-Benutzerkontensteuerung ist aktiviert
Wenn Zielgeräte einer Arbeitsgruppe gehören, nicht aber der Domäne des Active Directory gehören, deaktivieren Sie die Remote-Benutzerkontensteuerung auf den Zielgeräten:
- Führen Sie die Eingabeaufforderung als Administrator aus.
- Geben Sie den folgenden Befehl ein, um die Remote-Benutzerkontensteuerung zu deaktivieren:
- Starten Sie das Zielgerät neu.
Genauere Informationen über die Benutzerkontensteuerung finden Sie auf der Website von Microsoft:
Es gibt keine freigegebenen Ordner
Um eine Remote-Installation mit Windows-Mitteln durchführen zu können, sind folgende administrative freigegebene Ordner vorhanden sein: ADMIN$, C$ und IPC$. Manchmal können sie deaktiviert werden, um die Sicherheit des Betriebssystems zu verbessern.
- Führen Sie die Eingabeaufforderung als Administrator aus.
- Prüfen Sie mit folgendem Befehl, ob die Ordner ADMIN$, C$ und IPC$ vorhanden sind:
- Stellen Sie gegebenenfalls freigegebene administrative Ordner wieder her.
- Führen Sie die Eingabeaufforderung als Administrator aus.
- Geben Sie die folgenden Befehle ein:
REG ADD HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters /v AutoShareServer /t REG_DWORD /d 1 /fREG ADD HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters /v AutoShareWks /t REG_DWORD /d 1 /f - Starten Sie das Betriebssystem auf dem Zielgerät neu und überprüfen Sie noch einmal, ob diese Ordner vorhanden sind.
Genauere Probleme, die wegen der fehlenden freigegebenen Ordner auftreten können, finden Sie auf der Website von Microsoft.
Inkorrekter Status der Dienste LanmanServer, RPC und DCOM
Die Betriebssystem-Dienste LanmanServer, RPC und DCOM ermöglichen die Remote-Installation von Anwendungen. Damit die Aufgabe zur Remote-Installation einer Anwendung ausgeführt werden kann, müssen die Dienste LanmanServer, RPC und DCOM den Status „Running“ haben.
Überprüfen Sie den Status:
- Führen Sie die Eingabeaufforderung als Administrator aus.
- Geben Sie den folgenden Befehl ein:
Wenn ein anderer Status angezeigt wird, passen Sie die Einstellungen für den Start der Dienste in den Gruppenrichtlinien der Domäne oder über das lokale Snap-in des Dienstes (services.msc) an.
Datei- und Druckerfreigabe ist deaktiviert
Die Datei- und Druckerfreigabe ermöglicht, dass das Installationspaket auf das Zielgerät kopiert wird. So aktivieren Sie die Datei- und Druckerfreigabe:
- Drücken Sie die Tasten und „R“, tippen Sie „ncpa.cpl“ ein und klicken Sie auf OK.
- Öffnen Sie lokal auf dem betroffenen Gerät das Kontextmenü des Netzwerkadapters, der mit dem Administrationsserver oder einem Verteilungspunkt verbunden ist, und wählen Sie Eigenschaften.
- Aktivieren Sie das Kontrollkästchen Datei- und Druckerfreigabe aktiviert ist, und klicken Sie auf OK.
- Deaktivieren Sie den Netzwerkadapter und aktivieren Sie ihn erneut, oder starten Sie das Gerät neu, damit die Änderungen wirksam werden.
Die normale Funktion des Betriebssystems wurde gestört
Wenn das Problem mit dem Start einer Remote-Installation nicht auf allen Geräten im Netzwerk auftritt, prüfen Sie die häufigsten Ursachen des Problems auf diesen Geräten und folgen Sie den Tipps weiter unten:
- Die Systempartition des Festplattenspeicher ist vollständig belegt.
In diesem Fall können Dienste des Betriebssystem nicht mehr korrekt funktionieren. Geben Sie den Speicherplatz frei und starten Sie das Gerät neu. - Das Betriebssystem wartet auf einen Neustart nach der Installation von Windows-Updates.
Wenn die Installation nicht abgeschlossen wurde, kann die Aufgabe zur Remote-Installation gestört sein. Um das Problem zu beheben, starten Sie das Gerät neu. - Das Betriebssystem läuft schon seit längerer Zeit, ohne neu gestartet zu werden.
Starten Sie das Betriebssystem neu, wenn Sie es seit Monaten nicht neu gestartet haben. - Das WMI-Repository ist beschädigt.
Prüfen Sie seine Integrität und beheben Sie Probleme anhand der Anleitung auf der Website von Microsoft. - Systemdateien des Betriebssystems sind beschädigt.
Prüfen Sie die Integrität der Systemdateien des Betriebssystems und stellen Sie sie wieder her. Folgen Sie den Anweisungen auf der Website von Microsoft, um die Befehle unten korrekt einzugeben, und dann starten Sie das Gerät neu.
Vorgehensweise, wenn das Problem weiterhin besteht
- Folgen Sie weiteren Empfehlungen zur Netzwerkverfügbarkeit aus diesem Artikel.
- Wenn die Installation erfolgreich abgeschlossen wurde und die Meldung „Die Remote-Installation wurde auf dem Gerät erfolgreich abgeschlossen“ angezeigt wird, der Administrationsagent jedoch nicht verfügbar ist oder auf dem Geräteobjekt nicht angezeigt wird, lesen Sie die Empfehlungen in diesem Artikel.
- Wenn ein DPI-System (Deep Packet Inspection) oder Technologien zur Entschlüsselung und Analyse des Datenverkehrs (Verwendung der SSL-Untersuchung) als Teil von dritten Sicherheitslösungen in Ihrer Infrastruktur verwendet werden, versuchen Sie, eine Ausnahme für die Untersuchung der Verbindung zwischen dem Administrationsagenten auf dem verwalteten Zielgerät und dem Administrationsserver hinzuzufügen.
- Verwenden Sie zusätzliche zentralisierte Mittel zur Verteilung des Administrationsagenten:
- mithilfe der Gruppenrichtlinien von Active Directory
- über die Integration in ein Referenz-Betriebssystemabbild
- mithilfe von Dritthersteller-Tools zur zentralisierten Verteilung von Anwendungen
Wenn das Problem weiterhin besteht, senden Sie eine Anfrage an den technischen Support via Kaspersky CompanyAccount. In Ihrer Anfrage:
- Beschreiben Sie das Problem, hängen Sie Screenshots des Installationsfehlers an, geben Sie an, welche Schritte der Anleitung Sie durchgeführt haben, und stellen Sie die Ausgabe der Diagnosebefehle aus diesem Artikel bereit.
- Erfassen Sie Diagnoseinformationen anhand dieser Anleitung und hängen Sie erstellte Dateien an Ihre Anfrage an.
Nützliche Hinweise
Beheben von Netzwerkfehlern bei einer Remote-Installation des Kaspersky Security Center Administrationsagenten
Beheben von Fehlern wegen inkorrekter Konfiguration der Kontoberechtigungen bei einer Remote-Installation des Kaspersky Security Center Administrationsagenten
Erzwungene Bereitstellung mithilfe der Aufgabe zur Remote-Installation der Apps von Kaspersky Security Center
Start der von Kaspersky Security Center gebildeten autonomen Pakete