Problem mit zahlreichen Einträgen über PDK-Patches des Administrationsagenten im Kaspersky Security Center

Zuletzt aktualisiert: 30. März 2021 Artikel ID: 15477
 
 
 
 

Der Artikel bezieht sich auf:

  • Kaspersky Security Center 13 (Version 13.0.0.11247)
  • Kaspersky Security Center 12 (Version 12.0.0.7734)
 
 
 
 

Problem

Die Datenbank und die Liste mit den Namen der Updates werden mit dengleichen Informationen über PDK-Patches für den Administrationsagenten ausgefüllt.

Ursachen

Das Kaspersky Security Center generiert Patches auf jedem Gerät mit dem installierten Administrationsagenten, statt einen einheitlichen PDK-Patch für den Administrationsagenten zu generieren. Diese Patches unterscheiden sich nur durch die IDs.

Detaillierte Informationen über den PDK-Patch finden Sie weiter unten.

Lösung

  1. Laden Sie das Archiv mit dem Hilfsprogramm klsql2 herunter.
  2. Extrahieren Sie die Inhalte aus dem Archiv in einen Ordner auf dem Computer, auf dem der Administrationsserver installiert ist.
  3. Öffnen Sie die Datei „src.sql“ in einem Texteditor.
  4. Kopieren Sie in diese Datei die SQL-Anfrage für:
  5. Führen Sie die Datei „start.cmd“ als Administrator aus. Verwenden Sie dabei das Administratorkonto, das Sie zur Installation des Administrationsservers verwendet haben.

Die Ergebnisse der Ausführung der Anfrage werden in der Datei „result.xml“ gespeichert. Die alten Einträge über die PDK-Patches werden aus der Datenbank entfernt, wobei keine neuen mehr hinzugefügt werden.

 
 
 
 

Über den PDK-Patch

 
 
 
 
 
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