Fehler „Access denied“ beim Verbindungsaufbau über einen Proxyserver in Kaspersky Security 9.x für Microsoft Exchange Server
Der Artikel bezieht sich auf:
- Kaspersky Security 9.6 für Microsoft Exchange Server Maintenance Release 6 (Version 9.6.96.0)
- Kaspersky Security 9.5 für Microsoft Exchange Server Maintenance Release 5 (Version 9.5.153.0)
Problem
Anfragen von Kaspersky Security 9.x für Microsoft Exchange Server werden blockiert, wenn die Untersuchung des HTTPS-Datenverkehrs auf dem Proxyserver aktiviert ist.
Im Programmverlauf wird dabei die folgende Meldung angezeigt: „Error AntispamEngine: tpprov [ConnectionTmpl.h:133] eka::SystemException caught: .\src\ProxyAuthorizationUtil.cpp(178) SystemException - basic auth failed. http ret code:407: 0x80000045 (Access denied)“.
Ursache
Die Dienste Kaspersky Security Network und Enforced Anti-Spam Update Service verwenden zur Verbindung mit externen Kaspersky-Servern den Port 443, der möglicherweise geschlossen ist.
Lösung
Zur korrekten Funktion der Dienste von Kaspersky Security 9.x für Microsoft Exchange Server erstellen Sie eine erlaubende Regel für diese Dienste oder deaktivieren Sie die Untersuchung des HTTPS-Datenverkehrs.
So deaktivieren Sie die Untersuchung von HTTPS-Verbindungen auf dem Forefront Threat Management Gateway (Forefront TMG):
- Öffnen Sie die Verwaltungskonsole des Forefront TMG.
- Im Stamm der Verwaltungskonsole wählen Sie den Serverknoten Web Access Policy.
- Auf dem Tab Tasks wählen Sie Configure HTTPS inspection.
- Gehen Sie auf General und deaktivieren Sie das Kontrollkästchen Enable HTTPS inspection.
- Klicken Sie auf OK.
- Klicken Sie auf Apply in der Verwaltungskonsole des Forefront TMG.
Die Untersuchung von HTTPS-Verbidnungen wird deaktiviert.