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Solución de problemas de conexión entre el Agente de red para Windows y el Servidor de administración

Última actualización: 18 de junio de 2024 ID: 12776
 
 
 
 
Mostrar las aplicaciones y versiones a las que hace referencia este artículo
  • Kaspersky Security Center 14.2 (versión 14.2.0.26967)
  • Kaspersky Security Center 14 (versión 14.0.0.10902)
 
 
 
 

Problema

  • El Agente de red se instaló correctamente de forma remota, pero el objeto del dispositivo administrado de destino no apareció en el Servidor de administración. O bien el objeto apareció, pero no hay ninguna señal de que el Agente de red esté instalado en él.
  • La instalación remota simultánea del Agente de red y el paquete de la aplicación se ejecuta al 50 % y se detiene después del mensaje de que el Agente se ha instalado correctamente. El Registro de eventos en la interfaz de la consola muestra que la aplicación no se está instalando.
  • La conexión al dispositivo administrado se pierde después de instalar una nueva versión del Agente de red sobre una anterior. Una tarea muestra un mensaje de que debe reiniciar el dispositivo administrado.
  • La verificación de la conexión del Agente de red al Servidor de administración mediante la utilidad klnagchk.exe finaliza con un error.
  • La instalación remota del Agente de red se detiene en el evento "En ejecución (32 %) (no se puede acceder al dispositivo)" o "El servicio de instalación se está ejecutando en este dispositivo. Espere...".
    El servicio del Agente de red en el dispositivo de destino no se está ejecutando, y cuando intenta iniciar cualquier componente:
    • aparece un evento sobre los archivos emcat.dl y em.dll en el registro de la aplicación de Windows: "Información 1603. El archivo C:\Archivos de programa (x86)\Kaspersky Lab\NetworkAgent\em.dll está en uso. Cierre esa aplicación y vuelva a intentarlo".
    • El Agente de red se bloquea con el error "Nombre de la aplicación con errores: klnagent.exe, versión: 14.2.0.26967, marca de tiempo: 0xa0f42d48 Nombre del módulo con errores: KERNELBASE.dll, versión: 6.1.7601.17514, marca de tiempo: 0x4ce7bafa <...>".

Causa

  • Configuración incorrecta del paquete o la directiva del Agente de red.
  • El servicio del Agente de red (klnagent) falla.
  • Un software de terceros bloquea los archivos del Agente de red.
  • No hay conectividad entre el Agente de red y el Servidor de administración.

Solución

Reinicie el sistema operativo del dispositivo de destino y asegúrese de que haya suficiente espacio en el disco. Si el error continúa, existen varias soluciones.

 
 
 
 

Solución 1. Buscar dispositivos no asignados

 
 
 
 

Solución 2. Verificar la configuración de la conexión en el paquete del Agente de red que la tarea distribuye

 
 
 
 

Solución 3. Verificar si está instalada la actualización KB3063858 en los dispositivos con sistemas operativos desactualizados

 
 
 
 

Solución 4. Comprobar si el servicio del Agente de red se inicia y si sus archivos se bloquean

 
 
 
 

Solución 5. Comprobar si el Agente de red ya está instalado

 
 
 
 

Solución 6. Comprobar si se puede acceder al Servidor de administración desde el dispositivo de destino

 
 
 
 

Qué hacer si el problema continúa

 
 
 
 
 
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