Problema con varias entradas sobre los parches PDK del Agente de red en Kaspersky Security Center
Este artículo comprende las siguientes versiones:
- Kaspersky Security Center 13 (versión 13.0.0.11247)
- Kaspersky Security Center 12 (versión 12.0.0.7734)
Problema
La base de datos y la lista de nombres de parches están llenas de entradas similares sobre los parches PDK para el Agente de red.
Motivo
Kaspersky Security Center genera parches en cada dispositivo que tiene el Agente de red instalado en lugar del parche PDK único para el Agente de red. Estos parches solo difieren en sus ID.
Para obtener más información sobre el parche PDK, consulte a continuación.
Solución
- Descargue el archivo con la herramienta klsql2.
- Extraiga el contenido del archivo en cualquier carpeta en un equipo que tenga instalado el Servidor de administración.
- Abra el archivo src.sql con un editor de texto.
- Copie una solicitud SQL en el archivo para lo siguiente:
- Ejecute el archivo start.cmd como administrador mediante la cuenta utilizada para la instalación del Servidor de administración.
Los resultados se guardarán en el archivo result.xml. Las entradas antiguas sobre parches PDK se eliminarán y no se añadirán nuevas entradas.
¿Qué es un parche PDK?
Los parches PDK se generan a partir de bibliotecas descargadas junto con las bases de datos antivirus. Se utilizan para actualizar la versión de la biblioteca en Kaspersky Security Center. Por ejemplo, se forman dos parches PDK para la biblioteca OpenSSL: uno para el Agente de red y otro para el Servidor de administración.
Para instalar el parche PDK para el Servidor de administración, apruébelo en la Consola de administración:
Para el Agente de red, el parche PDK se instala automáticamente y aparece en la lista como información.