Erreur 408 « Request Timeout » lors de l’utilisation de Kaspersky Scan Engine
Dernière mise à jour : 7 décembre 2020
Article ID : 15644
Erreur 408 « Request Timeout » lors d’envoi des requêtes avec un délai d’attente
Cause
- Si vous recevez la réponse avant que le délai d’attente défini soit atteint et qu’elle comporte le message d’erreur « Session Timeout », le problème est dû au délai d’attente de la session dans Kaspersky Scan Engine. Exemple de la réponse :
HTTP/1.0 408 Request Timeout
Connection: close
Content-Type: text/plain
Server: KAVHTTPD/1.0
X-KAV-ProtocolVersion: 3
Date: Tue, 13 Oct 2020 09:43:07 GMT
Content-Length: 35
{
"error": "Session Timeout"
}
Connection: close
Content-Type: text/plain
Server: KAVHTTPD/1.0
X-KAV-ProtocolVersion: 3
Date: Tue, 13 Oct 2020 09:43:07 GMT
Content-Length: 35
{
"error": "Session Timeout"
}
- Si vous recevez la réponse après le délai spécifié dans la requête et qu’elle contient le message d’erreur «scanResult»: «SERVER_ERROR», le problème est dû au délai d’attente de la tâche d’analyse. Exemple de la réponse :
HTTP/1.0 408 Request Timeout
Connection: close
Content-Type: text/plain
Server: KAVHTTPD/1.0
X-KAV-ProtocolVersion: 3
Date: Tue, 13 Oct 2020 10:43:20 GMT
Content-Length: 97
{
"object": "Memory",
"scanResult": "SERVER_ERROR"
}
Connection: close
Content-Type: text/plain
Server: KAVHTTPD/1.0
X-KAV-ProtocolVersion: 3
Date: Tue, 13 Oct 2020 10:43:20 GMT
Content-Length: 97
{
"object": "Memory",
"scanResult": "SERVER_ERROR"
}
Solution
- Pour éliminer l'erreur « Session Timeout », augmentez le délai d’attente de la session. Pour ce faire, ouvrez le fichier de configuration /etc/kavhttpd.xml et spécifiez une valeur plus élevée pour le paramètre SessionTimeout. Vous pouvez également augmenter le délai d’attente de la session dans le panneau de configuration de Kaspersky Scan Engine. (voir les instructions ci-dessous).
- Pour éliminer l'erreur «scanResult»: «SERVER_ERROR», augmentez le délai d’attente de la tâche d’analyse. Pour le faire :
- Si vous utilisez API v3.0, augmentez la valeur du paramètre timeout dans la structure JSON envoyée.
- Si vous utilisez API v1.0 ou v2.0, augmentez la valeur dans l’en-tête HTTP X-KAV-Timeout.
Erreur 408 « Request Timeout »
Lors de l’analyse de petits fichiers composés, Kaspersky Scan Engine peut renvoyer la réponse avec le message d’erreur 408 «Request Timeout». La réponse peut contenir le message d’erreur suivant :
{
"object": "Memory", "scanResult": "SERVER_ERROR"
}
"object": "Memory", "scanResult": "SERVER_ERROR"
}
Ou le message d’erreur suivant :
{
"error": "Session Timeout"
}
"error": "Session Timeout"
}
L’erreur peut survenir lors de l’analyse :
- des archives,
- des images disque compressées,
- des paquets d’installation aux formats MSI, EXE ou APK,
- des fichiers Java aux formats JAR, EAR ou WAR.
Cause
Ces fichiers malgré leur petite taille peuvent contenir un grand nombre de sous-objets. L’analyse de ses sous-objets nécessite un temps suffisant.
Solution
- Augmentez le délai d’attente de la session. Pour ce faire, ouvrez le fichier de configuration /etc/kavhttpd.xml et spécifiez une valeur plus élevée pour le paramètre SessionTimeout. Vous pouvez également augmenter le délai d’attente de la session dans la console Web de Kaspersky Scan Engine. (voir les instructions ci-dessous).
- Augmentez le délai d’attente de la tâche d’analyse. Pour le faire :
- Si vous utilisez API v3.0, augmentez la valeur du paramètre timeout dans la structure JSON envoyée.
- Si vous utilisez API v1.0 ou v2.0, augmentez la valeur dans l’en-tête HTTP X-KAV-Timeout.
Comment augmenter le délai d’attente de la session via la console Web de Kaspersky Scan Engine
- Ouvrez la console Web de Kaspersky Scan Engine et accédez à la section Settings → Scanning.
- Dans le champ Object scan timeout (ms) définissez le délai d’attente en millisecondes.
Le temps spécifié dans ce champ doit être suffisant pour établir la connexion, transférer le fichier à Kaspersky Scan Engine, analyser le fichier et envoyer la réponse. Nous recommandons de définir un délai suffisamment long pour transférer et analyser tous les fichiers que vous envisagez de vérifier.
Le délai d’attente est augmenté.