Messages « Un problème a été détecté lors de l'analyse du certificat » et « Il est impossible de garantir l'authenticité du domaine auquel la connexion chiffrée est en train d'être établie » à la tentative d'ouvrir un site
Les informations s'appliquent à :
- Kaspersky Basic, Standard, Plus, Premium,
- Kaspersky Anti-Virus,
- Kaspersky Internet Security,
- Kaspersky Total Security,
- Kaspersky Security Cloud,
- Kaspersky Small Office Security.
Problème
À une tentative d'ouvrir un site, le message « Un problème a été détecté lors de l'analyse du certificat ? » et « Il est impossible de garantir l'authenticité du domaine auquel la connexion chiffrée est en train d'être établie » s'affiche.
Cause
Le site peut être dangereux car un problème a été detécté avec son certificat. Les personnes malveillantes peuvent voler vos identifiants et autres données confidentielles. Nous déconseillons de continuer vers ce site Internet. Vous trouverez ci-dessous les causes possibles du problème.
Si vous avez modifié les paramètres d’analyse des connexions chiffrées définis par défaut, le message peut s’afficher lors du fonctionnement d’une application installée sur l’ordinateur. Pour éviter ce problème, rétablissez les paramètres par défaut de l’analyse des connexions chiffrées.
Solution
Si vous êtes sûr que le site n'est pas dangereux, par exemple, c'est le site officiel de Microsoft ou le site de votre banque que vous visitez régulièrement, ajoutez le site en question dans les adresses de confiance pour que l'application de Kaspersky n'analyse plus la connexion à ce site, voir les instructions ci-dessous pour :
- Kaspersky Basic, Standard, Plus, Premium,
- Kaspersky Anti-Virus, Kaspersky Internet Security, Kaspersky Total Security, Kaspersky Security Cloud, Kaspersky Small Office Security.
Si le message s'affiche lorsque vous ouvrez un site inconnu, vous pouvez autoriser de poursuivre vers ce site cette fois :
- si le message s'affiche dans le navigateur, cliquez sur Afficher les détails → Je souhaite continuer.
- si le message s'affiche dans une fenêtre pop-up de l'application, cliquez sur Continuer.
Si vous n'êtes pas sûr que le site n'est pas dangereux, vérifiez-le sur Kaspersky Threat Intelligence Portal avant de l'ouvrir.
Problèmes possibles avec le certificat qui pourraient causer cet avertissement
En analyse la connexion à un site, l'application de Kaspersky vérifie son certificat. Vous trouverez ci-dessous la liste les problèmes possibles avec le certificat qui pourraient causer cet avertissement :
- Le certificat peut être révoqué. Par exemple, le certificat peut être révoqué à la demande du propriétaire si son site a été piraté.
- Le certificat a été émis illégalement. Le certificat doit être émis dans un centre de certification après avoir passé l'audit avec succès.
- Les mises à jour des certificats racine de Windows peuvent manquer sur l’ordinateur. Par exemple, le certificat racine DST Root CA X3 utilisé à la base des certificats des sites dans le navigateur a expiré le 30 septembre 2021. Pour consulter le certificat de Windows sur lequel le certificat du site est basé, dans l’avertissement, cliquez sur Consulter le certificat et accédez à l’onglet Chemin d’accès de certification. Pour apprendre comment mettre à jour les certificats racine de Windows 7, 8, 8.1, 10 et 11, consultez les instructions ci-dessous.
- La chaîne des certificats est violée. Les certificats sont vérifiés par chaîne, allant d'un certificat racine auto-signé à un certificat racine de confiance fourni par le centre de certification. Les certificats intermédiaires servent à signer (confirmer) un autre certificat de la chaîne.
La chaîne des certificats peut être violée dans les cas suivants :- La chaîne consiste en un certificat signé automatiquement. Ce certificat n'est pas validé dans un centre de certification et peut être dangereux.
- La chaîne ne se termine pas par un certificat racine de confiance.
- La chaîne contient des certificats qui ne sont pas conçus pour signer d'autres certificats.
- Le certificat racine ou intermédiaire a expiré ou sa période de validité n'est pas encore venue. Le centre de certification émet le certificat pour une période de validité déterminée.
- La chaîne ne peut pas être formée.
- Le domaine indiqué dans le certificat ne correspond pas au site Internet avec lequel la connexion est établie.
- Le certificat n'est pas destiné à confirmer l'authenticité du nœud. Par exemple, le certificat peut être destiné uniquement à chiffrer la connexion entre le site et l'utilisateur.
- La politique d'utilisation du certificat est violée. La politique d'utilisation du certificat est un ensemble de règles qui déterminent l'utilisation du certificat avec les exigences de sécurité spécifiques. Chaque certificat possède au moins une politique avec laquelle il doit être conforme. Si plusieurs politiques existent pour ce certificat, il doit être conforme avec toutes ces politiques.
- La structure du certificat a été violée.
- Une erreur de vérification de la signature du certificat est survenue.
Comment désactiver les messages sur un problème de certificat pour un site en l'excluant de l'analyse dans Kaspersky Basic, Standard, Plus et Premium
- Dans la fenêtre principale de l'application de Kaspersky cliquez sur
.
- Accédez à la section Paramètres de sécurité, faites basculer vers le bas vers le bloc Paramètres avancés et cliquez sur Paramètres du réseau.
- Faites basculer vers le bas, cliquez sur Adresses de confiance → Ajouter.
- Spécifiez l'adresse du site indiquée dans le message sur le problème de certificat. Laissez l'état Actif sélectionné par défaut et cliquez sur Ajouter.
- Cliquez sur Enregistrer.
- Cliquez sur Enregistrer → Confirmer.
Le site est ajouté aux exclusions de l'analyse
Comment désactiver les messages sur un problème de certificat pour un site en l'excluant de l'analyse dans Kaspersky Anti-Virus, Kaspersky Internet Security, Kaspersky Total Security, Kaspersky Security Cloud et Kaspersky Small Office Security
-
Vous pouvez désactiver les messages sur un problème de certificat pour un site que vous connaissez ou visitez régulièrement en l'excluant de l'analyse dans les paramètres de l'application de Kaspersky :
- Dans la fenêtre principale de l'application cliquez sur le bouton
.
- Accédez à la section Paramètres du réseau et cliquez sur Adresses de confiance (Configurer les exclusions dans la version 21.2 et versions précédentes).
- Cliquez sur Ajouter.
- Spécifiez l'adresse du site indiqué dans le message avec le problème de certificat. Définissez l'état Actif et cliquez sur Ajouter.
- Cliquez sur Enregistrer.
- Cliquez sur Enregistrer, ensuite sur Oui dans la fenêtre de confirmation.
Le site est ajouté aux exclusions de l'analyse.
Comment mettre à jour les certificats racine sur Windows 7, 8, 8.1, 10 et 11
Les certificats racine sont mis à jour.
- Téléchargez l'archive CA.zip.
- Décompressez la dans le dossier C:\CA. Si ce dossier n’existe pas, créez-en un.
Vérifiez que les fichiers de l'archive se trouvent dans ce dossier. - Lancez l'invite de commandes en tant qu'administrateur. Pour les instructions, consultez cet article.
- Exécutez la commande :
Si une erreur se produit, vérifiez que la commande a été correctement saisie, notamment que C:\CA\updroots.exe est suivi d'une espace.
Une fois la commande exécutée, une nouvelle ligne s’affichera à l’écran. Cela signifie que la mise à jour a réussi.
- Redémarrez l'ordinateur.
Les certificats racine sont mis à jour. Nous recommandons d’installer également toutes les mises à jour disponibles de Windows ainsi que de votre navigateur.
Que faire si le problème persiste
Si vous avez exclu un site de l'analyse des connexions chiffrées mais que le message sur le problème de certificat s'affiche de nouveau, relancez l'application de Kaspersky ou redémarrez l'ordinateur.
Si le problème persiste, contactez le service clientèle de Kaspersky en sélectionnant le sujet de votre demande.
Le support de Kaspersky Free n'est pas fourni. Pour résoudre d’éventuels problèmes, recherchez la réponse sur le forum ou créez-y un nouveau topic en décrivant le souci rencontré.
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