Erreur « Le service Windows Installer est occupé »
Dernière mise à jour : 8 février 2024
Article ID : 13840
Problème
Lors de l’installation d’une application de Kaspersky, le message d’erreur « Le service Windows Installer est occupé » peut s’afficher.
Cause
Un autre programme est en cours d'installation. Le service d’installation de Windows ne permet d’installer qu’une application à la fois.
Solution 1
- Patientez jusqu'à ce que l'installation de l'autre application soit terminée.
- Redémarrez le système d'exploitation et réessayez d'installer l'application de Kaspersky.
Solution 2
Si la solution n'a pas résolu le problème, utilisez le programme Process Explorer :
- Téléchargez et décompressez l'archive ProcessExplorer.zip.
- Cliquez avec le bouton droit sur le fichier procexp.exe et dans le menu contextuel sélectionnez Exécuter en tant qu'administrateur (ou Exécuter comme administrateur, selon la version du système d'exploitation).
- Appuyez sur les touches Ctrl + Maj + F sur le clavier, tapez _MSIExecute dans la ligne de recherche et cliquez sur Search. Le processus d’installation en cours d’exécution s’affichera dans la fenêtre.
- Terminez ce processus et réessayez d'installer l'application de Kaspersky.
- Si le problème persiste : :
- Trouvez le service de Windows auquel le processus lancé appartient et arrêtez-le durant l’installation de l’application de Kaspersky.
- Relancez l’installation de l’application.
- Démarrez le service de Windows.
L'erreur est souvent causée par le Service d'indexation de Windows. Dans ce cas, vous verrez le processus SearchFilterHost.exe dans les résultats de la recherche dans Process Explorer.
Que faire si le problème persiste
Si l'erreur persiste, contactez le service clientèle de Kaspersky.