Message d'erreur « Une erreur fatale s'est produite durant l'installation » et le code d'erreur 0x80004005 dans le journal d'installation à la tentative de désactiver Windows Defender lors de l'installation de Kaspersky Endpoint Security for Windows
Les informations s'appliquent à :
- Kaspersky Endpoint Security 12.0.0 for Windows (version 12.0.0.465),
- Kaspersky Endpoint Security 11.11.0 for Windows (version 11.11.0.452),
- Kaspersky Endpoint Security 11.10.0 for Windows (version 11.10.0.399),
- Kaspersky Endpoint Security 11.9.0 for Windows (version 11.9.0.351),
- Kaspersky Endpoint Security 11.8.0 for Windows (version 11.8.0.384),
- Kaspersky Endpoint Security 11.7.0 for Windows (version 11.7.0.669),
- Kaspersky Endpoint Security 11.6.0 for Windows (version 11.6.0.394),
- Kaspersky Endpoint Security 11.5.0 for Windows (version 11.5.0.590),
- Kaspersky Endpoint Security 11.4.0 for Windows (version 11.4.0.233),
- Kaspersky Endpoint Security 11.3.0 for Windows (version 11.3.0.773),
- Kaspersky Endpoint Security 11.2.0 for Windows (version 11.2.0.2254).
Problème
Le message d'erreur « Une erreur fatale s'est produite durant l'installation » peut s'afficher lors de l'installation de l'application.
Lorsque cette erreur ce produit, le journal d'installation contient les entrées suivantes :
DisableWindowsDefender: Failed to access local group policy. Error 0x80004005.
DisableWindowsDefender: DisableWindowsDefender: finished. Return value 1603.
Cause
Le programme d'installation de l'application appelle la fonction OpenLocalMachineGPO(GPO_OPEN_LOAD_REGISTRY) et désigne sa stratégie de groupe locale qui permet de désactiver Windows Defender afin d'apporter toutes les modifications nécessaires à l'installation de l'application. Si la possibilité de désactiver Windows Defender sur le poste cible est bloquée par une stratégie de domaine, une erreur se produit.
Solution
- Attribuez à ce poste la stratégie GPO (Group Policy Object) avec les paramètres par défaut Default Domain Policy où tous les paramètres relatifs à Windows Defender possèdent la valeur Not configured.
- Forcez l'application de la stratégie de groupe sur le poste cible.
- Redémarrez l'ordinateur.
- Relancez l'installation de l'application.
Que faire si le problème persiste
Si la solution ci-dessus n'a pas résolu le problème :
- Supprimez temporairement le poste du domaine Active Directory.
- Réinitialisez les stratégies de groupe locales.
- Relancez l'installation de l'application.
- Une fois l'installation réussie, ajoutez l'ordinateur au domaine Active Directory.
Si vous ne parvenez pas à éliminer le problème, déposez une demande auprès du support technique de Kaspersky via Kaspersky CompanyAccount en décrivant en détail le problème. Avant de déposer une demande, prenez connaissance des informations à fournir au support technique.