Le service kladminserver ne démarre pas après la mise à niveau de Kaspersky Security Center
Problème
Après la mise à niveau de Kaspersky Security Center vers la version 13.2 le service kladminserver peut ne pas démarrer et le journal des événements peut contenir le message suivant :
« Le service 'kladminserver' a été arrêté à cause d'une erreur. #1950 (102) Generic db error: "102 'Incorrect syntax near '('.{42000};' LastStatement='EXEC grp_sync_subgroups'" ».
Cause
Le problème est dû au niveau de compatibilité de la base de données incorrect spécifié dans dans Microsoft SQL Server.
Solution
Modifiez le niveau de compatibilité de la base de données dans Microsoft SQL Server Management Studio à l’aide de la commande suivante :
Si vous utilisez Microsoft SQL Server Express Edition, téléchargez la version gratuite de Microsoft SQL Server Management Studio.
Spécifiez le niveau de compatibilité selon la version de Microsoft SQL Server utilisée :
Versions de Microsoft SQL Server | Niveau de compatibilité |
---|---|
2014 (12.x) | 120 |
2016 (13.x) | 130 |
2017 (14.x) | 140 |
2019 (15.x) | 150 |
Vous pouvez également modifier le niveau de compatibilité de la base de données via l'interface de SQL Management Studio. Pour les instructions, consultez le site du support de Microsoft.
Que faire si le problème persiste
Si vous ne parvenez pas à éliminer le problème, déposez une demande auprès du support technique de Kaspersky via Kaspersky CompanyAccount en décrivant en détail le problème. Avant de déposer une demande, prenez connaissance des informations à fournir au support technique.