Résoudre les problèmes liés à l’installation ou à la désinstallation de l'Agent d'administration de Kaspersky Security Center
Afficher les applications et les versions auxquelles ces informations s'appliquent
- Kaspersky Security Center 14.2 (version 14.2.0.26967),
- Kaspersky Security Center 14.0 (version 14.0.0.10902).
- Kaspersky Security Center 13.2 (version 13.2.0.1511),
- Kaspersky Security Center 13.1 (version 13.1.0.8324),
- Kaspersky Security Center 13.0 (version 13.0.0.11247).
Problème
Les messages d’erreur système suivants peuvent s’afficher lors de l'installation de l'Agent d'administration :
- « Erreur 25003. System error 0x1F (Un appareil attaché au système ne fonctionne pas) »
- « Erreur (System error 0x80090006 (Signature non valide.)) »
- « (1192/0x0 ("System container 'LOC-PUB-6EEB50F8D2EB46029DB4CCB77E0DA651' is corrupt") »
- D’autres erreurs
L’utilisation de l’utilitaire cleaner pour la suppression des installations précédentes de l'Agent d'administration ne permet pas d’éliminer le problème recontré.
Cause
- Le stockage protégé du système d’exploitation de l’appareil est endommagé ce qui empêche l’installation de l'Agent d'administration.
- La version de l'Agent d'administration à installer est incompatible avec la version du système d’exploitation.
- Il existe des fichiers et des entrées restant des installations précédentes de l’application empêchant son installation ou son désinstallation.
Solution
Si le problème est lié au stockage protégé du système d’exploitation endommagé sur l’appareil, restaurez-le en suviant ces instructions.
Vérifiez si l'Agent d'administration prend en charge le système d’exploitation.
Si le problème survient à cause des résidus des installations précédentes, collectez les informations de diagnostic et déposez une demande auprès du support technique.
Comment restaurer le stockage protégé
- Lancez l'invite de commandes en tant qu'administrateur et utilisez cette commande pour rechercher les clés de l’Agent d’administration dans le dossier du stockage protégé :
- Redémarrez l'appareil et installez l’Agent d’administration.
Si le problème persiste :- Restaurez l’image Windows à l’aide des commandes :
DISM.exe /Online /Cleanup-image /Scanhealth
DISM.exe /Online /Cleanup-image /Restorehealth
sfc /scannow - Redémarrez l'appareil et réessayez d'installer l’Agent d’administration.
- Restaurez l’image Windows à l’aide des commandes :
Si des clés de l’Agent d’administration sont détectés, supprimez-les manuellement du dossier du stockage : %ProgramData%\Microsoft\Crypto\RSA\MachineKeys
Si les erreurs système persistent, réinstallez le système d’exploitation Windows ou contactez le support technique de Microsoft.
Que faire si le problème persiste
Déposez une demande auprès du support technique de Kaspersky via Kaspersky CompanyAccount.
Dans cette demande décrivez en détail votre problème et joignez :
- les captures d’écran des erreurs,
- un rapport créé à l’aide de l’utilitaire Getsysteminfo avec l'option Include Windows event logs activée sur l’appareil posant le problème,
- les journaux d'installation de l'Agent d'administration,
- les branches du registre exportées suivantes (voir les instructions) :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\
HKEY_CLASSES_ROOT\Installer\Products\