L’Agent d’administration ne se connecte pas au Serveur d'administration

Dernière mise à jour : 15 février 2024 Article ID : 12776
 
 
 
 
Afficher les applications et les versions auxquelles ces informations s'appliquent
  • Kaspersky Security Center 14.2 (version 14.2.0.26967),
  • Kaspersky Security Center 14.0 (version 14.0.0.10902).
  • Kaspersky Security Center 13.2 (version 13.2.0.1511),
  • Kaspersky Security Center 13.1 (version 13.1.0.8324),
  • Kaspersky Security Center 13.0 (version 13.0.0.11247).
 
 
 
 

Problème

  • L’installation à distance du paquet d’installation de l’Agent d’administration a réussi mais l’appareil cible n’apparaît pas dans les appareils administrés sur le Serveur d'administration. Il se peut également que l’appareil ait été ajouté mais il est indiqué que l’Agent d’administration n’est pas installé.
  • L’installation à distance simultanée de l’Agent d’administration et d’une application de protection s’arrête à 50 % après le message notifiant que l’installation de l’Agent d’administration a réussi. Vous pouvez voir dans le journal des événements dans l’interface de la Console d’administration que l’installation de l’application de protection n’a pas été effectuée.
  • La connexion à l’appareil a été intterompue après l’installation d’une nouvelle version de l'Agent d'administration par-dessus la version précédente. Un message sur la nécessité du redémarrage de l’appareil administré apparaît dans la tâche.
  • La vérification de la connexion de l’Agent d’administration au Serveur d'administration à l’aide de l’utilitaire klnagchk.exe échoue.
  • L’installation à distance de l’Agent d’administration s’arrête à l’état : « En cours d’exécution (32 %) (Appareil inaccessible) » ou « Le service d’installation est lancé sur l’appareil. Veuillez patienter... ».
    Le service de l’Agent d’administration sur l’appareil cible n’est pas démarré et l’un des comportements suivants est observé à une tentative de lancer n’importe quel module :
    • Un événement avec les fichiers emcat.dl et em.dll apparaît dans le journal des applications de Windows : « Information 1603. Le fichier C:\Program Files (x86)\Kaspersky Lab\NetworkAgent\em.dll est utilisé. Fermez cette application et réessayez ».
    • L’Agent d’administration se plante en affichant le message d’erreur suivant : « Nom de l’application défaillante : klnagent.exe, version : 14.2.0.26967, horodatage : 0xa0f42d48. Nom du module défaillant : KERNELBASE.dll, version : 6.1.7601.17514, horodatage 0x4ce7bafa... ».

Cause

  • Les paramètres non valides sont utilisés dans les propriétés du paquet d’installation de l’Agent d’administration ou de sa stratégie.
  • Le service de l’Agent d’administration a échoué.
  • Les fichiers de l’Agent d’administration sont bloqués par un logiciel tiers.
  • Il existe un problème de communication entre l’Agent d’administration et le Serveur d'administration.

Solution

Il existe plusieurs solutions des problèmes cités. Les deux premières solutions permettent de résoudre les problèmes du côté du Serveur d'administration, les solutions restantes résolvent les problèmes du côté des appareils administrés cibles.

 
 
 
 

Solution 1. Effectuez la recherche dans les appareils non définis

 
 
 
 

Solution 2. Vérifiez les paramètres de connexion dans l’Agent d’administration dans le paquet d’installation utilisé

 
 
 
 

Solution 3. Vérifiez que la mise à jour KB3063858 est installée sur les appareils avec les systèmes d'exploitation obsolètes.

 
 
 
 

Solution 4. Vérifiez si le service de l’Agent d’administration est en cours d’exécution et si ses fichiers ne sont pas bloqués

 
 
 
 

Solution 5. Vérifiez que l’Agent d’administration n’a pas été installé précédemment

 
 
 
 

Solution 6. Vérifiez si le Serveur d'administration est accessible depuis l’appareil en question

 
 
 
 

Que faire si le problème persiste

 
 
 
 
 
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