Error “Cannot connect to the application installation source”
Latest update: July 11, 2024
ID: 11007
This article concerns Kaspersky applications for home and mobile.
Issue
When installing a Kaspersky application, the “Cannot connect to the application installation source” error occurs.
Cause
- The PC has a firewall installed that blocks the Internet connection required for installation.
- The operating system has incorrect proxy server settings entered.
- Kaspersky servers are temporarily unavailable due to maintenance.
- The Windows 7 computer uses an old version of the Internet Explorer browser with the outdated TLS 1.0 protocol.
Solution
Solution for Windows 7
- Upgrade your Internet Explorer browser to version 11, which uses a modern, more secure version 1.2 of the TLS protocol:
- Enable using TLS 1.2 in the browser settings:
- Press + R on the keyboard.
- Type inetcpl.cpl to open the Internet Properties and click OK.
- Go to the Advanced tab, select the Use TLS 1.2 check box and click OK.
- Press + R on the keyboard.
Solution for other operating systems
- Try to install the application again later (in an hour or so).
- Make sure that a third-party firewall isn’t installed on your computer. The list of incompatible software and the instructions on removing it are available in this article.
- Make sure that Microsoft Defender Firewall doesn’t block the application’s Internet connection using the instructions.
- Try to connect to the Internet using your mobile phone:
- Change the DNS address in the network settings using this guide.
- Reset the network and proxy server settings.
What to do if the issue persists
If the issue persists, contact Kaspersky Customer Service.
You can look up your problem on our Forum or create a new topic with a detailed description of the issue.
If you require full Customer Service, purchase one of the supported Kaspersky applications for home.