Kaspersky Endpoint Security 12 for Windows
 
 

Error 0x8000ffff when installing Kaspersky Endpoint Security for Windows

Latest update: January 25, 2024 ID: 15565
 
 
 
 
Show applications and versions that this article concerns
  • Kaspersky Endpoint Security 12.4 for Windows (version 12.4.0.467)
  • Kaspersky Endpoint Security 12.3 for Windows (version 12.3.0.493)
  • Kaspersky Endpoint Security 12.2 for Windows (version 12.2.0.462)
  • Kaspersky Endpoint Security 12.1 for Windows (version 12.1.0.506)
  • Kaspersky Endpoint Security 12 for Windows (version 12.0.0.465)
  • Kaspersky Endpoint Security 11.11 for Windows (version 11.11.0.452)
  • Kaspersky Endpoint Security 11.10 for Windows (version 11.10.0.399)
  • Kaspersky Endpoint Security 11.9 for Windows (version 11.9.0.351)
  • Kaspersky Endpoint Security 11.8 for Windows (version 11.8.0.384)
  • Kaspersky Endpoint Security 11.7 for Windows (version 11.7.0.669)
  • Kaspersky Endpoint Security 11.6 for Windows (version 11.6.0.394)
 
 
 
 

Issue

During the installation of drivers for Kaspersky Endpoint Security for Windows, errors may occur.

Examples of errors:

  • InstallDriversDeferred: Failed to add a catalog file. Error 0x8000ffff.
    ***
    MSI (s) (14!30) [11:07:22:451]: Product: Kaspersky Endpoint Security 10 for Windows – Error 27300.Error installing driver kl1.sys_X86. Error: -2147418113.
    InstallDriversDeferred: InstallDriversDeferred: finished. Return value 1603.
  • InstallDriversRollback (1b38:20b8) [15:46:19:896]: Failed to execute driver package 'mklif.sys_x64'. Failed to remove a catalog file. Error 0x8000ffff.
    ***
    MSI (s) (60!E8) [15:46:19:688]: Product: Kaspersky Endpoint Security for Windows – Error 27300. Error installing driver mklif.sys_x64. Error: -2147418113.

The errors can be found in the application installation log.

Causes

Violations of operating system integrity: issues with cryptographic services, catalog database for CryptoAPI (CAT) drivers, and catalog signature validation.

Troubleshooting

To confirm that the issue is connected with cryptographic services, you can do the following:

  • Check the Application system log on the device where the application is installed. The log can contain the following events: “The Cryptographic Services service failed to initialize the Catalog Database. The error was: -2147418113 (0x8000ffff) : Catastrophic failure”.
  • Check if the %WINDIR%\System32\catroot2\dberr.txt file contains lines with the following error: "encountered JET error -583".
  • Check if the %WINDIR%\INF\setupapi.dev.log file contains lines with the error code 0x8000ffff. For example: “Error 0x8000ffff: Catastrophic failure”.

Solution

If you have detected the errors described above:

  1. Resolve the problem with the operating system yourself or contact Microsoft Support.
  2. Install the application once again.
 
 
 
 
 
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