Error “Denylist of keys corrupted” after upgrading Kaspersky Endpoint Security for Windows
Latest update: April 18, 2024
ID: 16038
Show applications and versions that this article concerns
- Kaspersky Endpoint Security 12.4 for Windows (version 12.4.0.467)
- Kaspersky Endpoint Security 12.3 for Windows (version 12.3.0.493)
- Kaspersky Endpoint Security 12.2 for Windows (version 12.2.0.462)
- Kaspersky Endpoint Security 12.1 for Windows (version 12.1.0.506)
- Kaspersky Endpoint Security 12 for Windows (version 12.0.0.465)
- Kaspersky Endpoint Security 11.11 for Windows (version 11.11.0.452)
- Kaspersky Endpoint Security 11.10 for Windows (version 11.10.0.399)
- Kaspersky Endpoint Security 11.9 for Windows (version 11.9.0.351)
- Kaspersky Endpoint Security 11.8 for Windows (version 11.8.0.384)
- Kaspersky Endpoint Security 11.7 for Windows (version 11.7.0.669)
- Kaspersky Endpoint Security 11.6.0 for Windows (version 11.6.0.394)
Issue
The “Denylist of keys corrupted” error occurs in the License section of Kaspersky Endpoint Security for Windows.
Cause
The denylist of keys is corrupted and cannot be read. The problem may occur when updating the application databases and modules.
Solution
Below are the problem solutions ranging from simple to complex. Try them in that order until the problem is resolved.
- Run the update task. In most cases, the denylist of keys will be updated along with the application databases and modules.
- Rollback the updates of the application databases and modules to the previous version using this guide.
- Generate a new key file: use your activation code for Kaspersky Endpoint Security for Windows. Remove the installed license key and activate the application again with the generated key file.
- Remove Kaspersky Endpoint Security for Windows and install it again using this guide.
What to do if the issue persists
- Check if there is enough free disc space for the database updates and application modules.
- Make sure that your device is operational and that there are no issues with the hardware configuration, the integrity of the hard drive or RAM cells.
- If you have problems downloading updates from the Kaspersky Security Center repository, follow these instructions.
- Verify that you are using supported application versions.
If the issue persists, collect a GetSystemInfo report with the Include Windows event logs option enabled and create a request to Kaspersky Technical Support through Kaspersky CompanyAccount.