Cannot access backup storage through profiles in Kaspersky Security 9.x for Microsoft Exchange Servers
This article refers to Kaspersky Security 9.5 for Microsoft Exchange Servers Maintenance Release 5 Hotfix 1 (version 9.5.10000.64)
Issue
When trying to access the backup storage of Kaspersky Security 9.x for Microsoft Exchange Servers under your account, you may receive the error message:
Cause:
Your account does not have enough rights on the database server.
Solution:
- Run Microsoft SQL Server Management Studio (or Microsoft SQL Server Management Studio Express) and connect to the SQL server.
- Go to Security → Logins and remove the Kse Administrators group.
- Select the database SecurityForExchange, then go to Security → Users and remove the Kse Administrators group. The database is called SecurityForExchange by default, but when installing you can specify any name.
- Go to Security → Logins and create a new login for the Kse Administrators group.
- In the left frame, select User Mapping and in the right frame in the Map column select the check box for the Kaspersky Security 9.x for Microsoft Exchange Servers database.
- Open the SecurityForExchange database properties.
- Go to Permissions. Click Search and add your new login for the Kse Administrators group.
- Select the check boxes in the Grant column for Connect and Select.
- Click ОК.
The rights on the database server for your new Kse Administrators login will be extended.
What to do if the issue persists
If the issue persists, submit a request to Kaspersky technical support via Kaspersky CompanyAccount. Please include a detailed description of the issue. Before contacting the support, see the guide on creating a request in the Knowledge Base.