kladminserver service fails to run after Kaspersky Security Center upgrade
This article concerns Kaspersky Security Center 13.2 (version 13.2.0.1511).
Issue
After Kaspersky Security Center is upgraded to version 13.2 the kladminserver may fail to run. The log will show the following event:
The service' kladminserver 'was stopped due to an error #1950 (102) Generic db error: "102 'Incorrect syntax near '('.{42000};' LastStatement='EXEC grp_sync_subgroups'".
Cause
The error occurs because of the incorrect database compatibility level specified in Microsoft SQL Server.
Solution
Change the database compatibility level in Microsoft SQL Server Management Studio using the command:
If you are using Microsoft SQL Server Express Edition, download the free version of Microsoft SQL Server Management Studio.
Specify the compatibility level depending on the Microsoft SQL Server version that you are using:
Microsoft SQL Server version | Compatibility level |
---|---|
2014 (12.x) | 120 |
2016 (13.x) | 130 |
2017 (14.x) | 140 |
2019 (15.x) | 150 |
You can also change the database compatibility level via the SQL Management Studio GUI. See the guide on the Microsoft website.
What to do if the solution did not help
If the issue persists, submit a request to Kaspersky technical support via Kaspersky CompanyAccount. Please include a detailed description of the issue. Before contacting the support, see the guide on creating a request in the knowledge base.