What to do if all Android devices do not connect to Kaspersky Security Center Administration Server
Show applications and versions that this article concerns
- Kaspersky Security Center 15.1 (version 15.1.0.20748)
- Kaspersky Security Center 14.2 (version 14.2.0.26967)
- Kaspersky Security Center 14 (version 14.0.0.10902)
Issue
Android devices do not connect to the Kaspersky Security Center Administration Server, the synchronization of Kaspersky Endpoint Security for Android with the Administration Server terminates with an error.
Cause
The problem is most likely due to expiration of an Administration Server mobile certificate.
Solution
Step 1. Reissue the Administration Server certificate
- Open Kaspersky Security Center and select Properties in the Administration Server context menu.
- Go to Administration Server connection settings → Certificates.
- In the Administration Server authentication by mobile devices block, select Certificate issued through Administration Server and make sure the certificate has expired in the Expires field.
- Click Reissue.
- In the block Connection address, select Use old connection address.
- In the block Activation term, pick Immediately and click OK.
Step 2. Update the expired certificate on Android devices
Reinstall Kaspersky Security 10 for Mobile on all devices to regain the control. It’s necessary because you can change the certificate only after reinstalling or updating the app.
- Delete the application on all devices.
- Reinstall the application on the devices in any convenient for you way (via an installation package, manually or via Google Play or App Store).
To disable the protection, use a one-time unlock code (the Anti-Theft code).
What to do if the issue persists
If the issue persists, collect diagnostic data and submit a request to Kaspersky Technical Support via Kaspersky CompanyAccount.
How to configure a reserve Administration Server certificate
- Open Kaspersky Security Center and select Properties in the Administration Server context menu.
- Go to Administration Server connection settings → Certificates.
- In the block Administration Server authentication by mobile devices, select Certificate issued through Administration Server and click Reissue.
- In the block Connection address, select Use old connection address.
- In the Activation termblock, select After this period expires, days and specify the number of days after which the reserve certificate will replace the current mobile certificate on the Administration Server. The update will be done before the current certificate expires.
- Click OK.