Incorrect display of devices in the Administration Console of Kaspersky Security Center
Latest update: December 29, 2023
ID: 15762
Show applications and versions that this article concerns
- Kaspersky Security Center 14.2 (version 14.2.0.26967)
- Kaspersky Security Center 14 (version 14.0.0.10902)
- Kaspersky Security Center 13.2 (version 13.2.0.1511)
- Kaspersky Security Center 13.1 (version 13.1.0.8324)
- Kaspersky Security Center 13 (version 13.0.0.11247)
Issue
Some devices may be displayed together in the Administration Console under a single icon with a name that changes constantly.
Cause
A hard drive image with the Network Agent installed has been copied without following the rules of deployment.
Solution
Try one of the following options:
- Reinstall the Network Agent
- Run the klmover utility with the -dupfix key
- Tighten the rule for detection of incorrectly copied devices
How to reinstall the Network Agent
- Remove the Network Agent on devices that have been incorrectly copied from the image, using third-party tools.
The Network Agent cannot be removed through the Kaspersky Security Center tools, because the Administration Server cannot distinguish between faulty devices, as they all share the same icon in the Administration Console.
- Install the Network Agent again.
How to run the klmover utility with the -dupfix key
- Open the Network Agent installation folder on faulty devices.
- Use third-party tools to run the klmover utility with the -dupfix key.
You cannot run the utility with the Kaspersky Security Center tools, because the Administration Server cannot distinguish between faulty devices, as they all share the same icon in the Administration Console.
- Delete the icon on which the faulty devices had been displayed before you run the utility.
How to tighten the rule for detection of incorrectly copied devices
- On the device with the Administration Server, import the REG-file from an archive below depending on your operating system architecture:
- For 32-bit operating systems — reg_file_x32.zip
- For 64-bit operating systems — reg_file_x64.zip
- Restart the Administration Server service.
Changing the NetBIOS name of a device results in an automatic “fix” of the incorrectly copied Network Agents. It is assumed that all of the copied devices have unique NetBIOS names.
What to do if the issue persists
If the issue persists, submit a request to Kaspersky technical support via Kaspersky CompanyAccount.