Kaspersky Security Center 12
 
 

Issue with multiple entries about Network Agent PDK patches in Kaspersky Security Center

Latest update: March 22, 2021 ID: 15477
 
 
 
 

The article concerns:

  • Kaspersky Security Center 13 (version 13.0.0.11247)
  • Kaspersky Security Center 12 (version 12.0.0.7734)
 
 
 
 

Issue

The database and the list of patch names are filled with similar entries about PDK patches for Network Agent.

Cause

Kaspersky Security Center generates patches on each device with the Network Agent installed instead of the single PDK patch for Network Agent. These patches only differ in their IDs.

For more information about the PDK patch, see below.

Solution

  1. Download the archive with the klsql2 tool.
  2. Extract the contents from the archive to any folder on a computer with the Administration Server installed.
  3. Open the src.sql file using a text editor.
  4. Copy a SQL request into the file for:
  5. Run the start.cmd file as administrator using the account used for installation of the Administration Server.

The results will be saved in the result.xml file. Old entries about PDK patches will be deleted and new entries will not be added.

 
 
 
 

What is a PDK patch

 
 
 
 
 
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