Error “System error 0x203A (The server is not operational)” or “Failed to delete task. Access denied” when deleting a remote installation task in Kaspersky Security Center

Latest update: December 18, 2023 ID: 15487
 
 
 
 
Show applications and versions that this article concerns
  • Kaspersky Security Center 14.2 (version 14.2.0.26967)
  • Kaspersky Security Center 14 (version 14.0.0.10902)
  • Kaspersky Security Center 13.2 (version 13.2.0.1511)
  • Kaspersky Security Center 13.1 (version 13.1.0.8324)
  • Kaspersky Security Center 13 (version 13.0.0.11247)
 
 
 
 

Issue

When deleting a remote installation task on the Administration Server or on the administrator’s computer with a standalone console installed, an error may occur:

  • “System error 0x203A (The server is not operational.)”.
  • “Failed to delete task "task_name". Access denied”, where task_name is a task name in Kaspersky Security Center specified by an administrator.

In the Kaspersky Event Log on the device with the Administration Server installed, you may see the event:

Failed to delete group policy object 'LDAP://CN={C4179929-65C1-449C-A3C0-D8E85CC08422},CN=Policies,CN=System,DC=bn,DC=loc': 'System error 0x203A (The server is not operational.)'

Cause

The error occurs when you are trying to delete the remote installation task with the Assign package installation in Active Directory group policies option selected.

When running a remote installation task through Active Directory group policies, a security group and a group policy object are created on domain controllers. If you delete such a task, related Active Directory objects will be deleted through the user account specified in the task settings.

The error can be caused by some problems on the Active Directory level or incorrect credentials in the task settings, e.g., an obsolete password or a user account that is no longer active.

Solution

Follow one or several of the recommendations below and try deleting the task once again:

  • Specify the correct password for the user account under which the task is launched.
  • Change the user account in the task properties. Make sure that the account is active, the password is correct and known to the administrator, and the account has all required permissions. Use these instructions.
  • Clear the Assign package installation in Active Directory group policies checkbox in the remote installation task properties. You may need to exclude managed devices from the task scope first.
  • Use the official Microsoft recommendations on how to fix the “The server is not operational” error related to Active Directory level issues.
 
 
 
 
 
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