Why applications are not downloaded from Microsoft Store if Kaspersky Security Center is used as a WSUS server
Latest update: January 10, 2024
ID: 15883
Show applications and versions that this article concerns
- Kaspersky Security Center 14.2 (version 14.2.0.26967)
- Kaspersky Security Center 14 (version 14.0.0.10902)
- Kaspersky Security Center 13.2 (version 13.2.0.1511)
- Kaspersky Security Center 13.1 (version 13.1.0.8324)
- Kaspersky Security Center 13 (version 13.0.0.11247)
Issue
If you use Kaspersky Security Center as a WSUS server, all the devices managed by it are prohibited from downloading applications from Microsoft Store.
Cause
This is a Microsoft limitation. For details, see the Microsoft website.
Solution
To allow the workstations to download updates from the Internet, perform the following steps:
- Make sure your user account has administrator permissions.
- Pause the Kaspersky Security Center Administration Server service.
- Run the command line.
- Specify the path to the klscflag.exe tool. By default, the tool is located in the Kaspersky Security Center installation folder:
C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security Center. - Run the following command:
klscflag.exe -fset -pv klserver -n KLWUS_WUA_DISABLE_CONN_TO_INET -t d -v 0
- Restart the Kaspersky Security Center Administration Server service.
If you want to continue using Kaspersky Security Center for distributing updates to workstations, restore the previous settings:
- Pause the Kaspersky Security Center Administration Server service.
- Run the command line.
- Specify the path to the klscflag.exe tool. By default, the tool is located in the Kaspersky Security Center installation folder:
C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security Center. - Run the following command:
klscflag.exe -fset -pv klserver -n KLWUS_WUA_DISABLE_CONN_TO_INET -t d -v 1
- Restart the Kaspersky Security Center Administration Server service.