Kaspersky Thin Client
 
 

How to enable the H.264 codec in Windows Server 2016

Latest update: July 30, 2024 ID: 16084
 
 
 
 
This article concerns Kaspersky Thin Client 2.0.
 
 
 
 

Issue

When connecting to Windows Server 2016 via Kaspersky Thin Client 2.0, you may experience severe image delays and uneven sound while watching videos.

Cause

The issue occurs because Windows Server 2016 by default does not support the H.264 codec for encoding an RDP session.

Solution

Enable the H.264 codec support by changing the Windows Server 2016 Group Policy. To do so:

  1. Press The Windows key on the keyboard.+R to open the Run window.
  2. Type gpedit.msc and click OK to run the Local Group Policy Editor.

Opening Local Group Policy Editor.

  1. Go to Computer configuration → Administrative Templates → Windows Components.
  2. Select Remote Desktop ServicesRemote Desktop Session Host.
  3. Select Remote Session Environment and click Prioritize H.264/AVC 444 graphics mode for Remote Desktop Connections.

Configuring the Remote Session Environment.

  1. Select Enabled and click OK.

Enabling the H.264 codec.

  1. Press The Windows key on the keyboard.+R to open the Run window again.
  2. Type cmd and click OK to run the command line.
  3. Run the command:
    gpupdate /force

Running the gpupdate /force command in the command line.

 
 
 
 
 
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