Solución de problemas de conexión entre el Agente de red para Windows y el Servidor de administración
Mostrar las aplicaciones y versiones a las que hace referencia este artículo
- Kaspersky Security Center 14.2 (versión 14.2.0.26967)
- Kaspersky Security Center 14 (versión 14.0.0.10902)
Problema
- El Agente de red se instaló correctamente de forma remota, pero el objeto del dispositivo administrado de destino no apareció en el Servidor de administración. O bien el objeto apareció, pero no hay ninguna señal de que el Agente de red esté instalado en él.
- La instalación remota simultánea del Agente de red y el paquete de la aplicación se ejecuta al 50 % y se detiene después del mensaje de que el Agente se ha instalado correctamente. El Registro de eventos en la interfaz de la consola muestra que la aplicación no se está instalando.
- La conexión al dispositivo administrado se pierde después de instalar una nueva versión del Agente de red sobre una anterior. Una tarea muestra un mensaje de que debe reiniciar el dispositivo administrado.
- La verificación de la conexión del Agente de red al Servidor de administración mediante la utilidad klnagchk.exe finaliza con un error.
- La instalación remota del Agente de red se detiene en el evento "En ejecución (32 %) (no se puede acceder al dispositivo)" o "El servicio de instalación se está ejecutando en este dispositivo. Espere...".
El servicio del Agente de red en el dispositivo de destino no se está ejecutando, y cuando intenta iniciar cualquier componente:- aparece un evento sobre los archivos emcat.dl y em.dll en el registro de la aplicación de Windows: "Información 1603. El archivo C:\Archivos de programa (x86)\Kaspersky Lab\NetworkAgent\em.dll está en uso. Cierre esa aplicación y vuelva a intentarlo".
- El Agente de red se bloquea con el error "Nombre de la aplicación con errores: klnagent.exe, versión: 14.2.0.26967, marca de tiempo: 0xa0f42d48 Nombre del módulo con errores: KERNELBASE.dll, versión: 6.1.7601.17514, marca de tiempo: 0x4ce7bafa <...>".
Causa
- Configuración incorrecta del paquete o la directiva del Agente de red.
- El servicio del Agente de red (klnagent) falla.
- Un software de terceros bloquea los archivos del Agente de red.
- No hay conectividad entre el Agente de red y el Servidor de administración.
Solución
Reinicie el sistema operativo del dispositivo de destino y asegúrese de que haya suficiente espacio en el disco. Si el error continúa, existen varias soluciones.
Solución 1. Buscar dispositivos no asignados
Si el dispositivo no aparece en la lista de dispositivos administrados después de que el Agente de red se haya instalado correctamente, es posible que se haya conectado de forma adecuada, pero que no se mueva de manera automática al grupo Dispositivos administrados. En ese caso, realice lo siguiente:
- Haga clic con el botón derecho en el Servidor de administración y elija Buscar.
- Introduzca las primeras letras del nombre del dispositivo enmascarado (por ejemplo, comp*) o su dirección IP, y haga clic en Buscar ahora.
Si encuentra el dispositivo, añádalo manualmente al grupo Dispositivos administrados.
Si no puede encontrar el dispositivo o si el valor de Última conexión al Servidor de administración del dispositivo encontrado está significativamente desactualizado, verifique el estado y la configuración de conexión del Agente de red en el dispositivo de destino usando la utilidad klnagchk.exe y luego intente otras soluciones de este artículo.
Solución 2. Verificar la configuración de la conexión en el paquete del Agente de red que la tarea distribuye
- Averigüe el nombre del paquete del Agente de red que está utilizando:
- Vaya a Tareas y elija Instalar aplicación en remoto.
- En el menú de la izquierda, haga clic en Configuración.
Encontrará el nombre del paquete en la sección Paquetes de instalación.
- Cierre la tarea, abra las propiedades del Servidor de administración, elija General y haga clic en Ver certificado del Servidor de administración.
- Cierre las propiedades del Servidor de administración. En la Consola de administración, vaya a Avanzado → Instalación remota → Paquetes de instalación.
- Haga clic con el botón derecho en el paquete requerido y abra sus propiedades.
- Vaya a Conexión y haga lo siguiente:
- Compruebe que la huella digital del certificado del Agente de red del campo Utilizar certificado de servidor coincida con la huella digital del certificado del Servidor de administración del paso 2.
Si los certificados no coinciden, elija para el Agente de red el mismo certificado que para el Servidor de administración en la carpeta %ProgramData%\KasperskyLab\adminkit\1093\cert\klserver.cer en el servidor. Lea este artículo para obtener más información. - Compruebe que se haya especificado el nombre correcto del Servidor de administración en el campo Servidor de administración y que se hayan configurado los puertos correctos.
Si la casilla de verificación Utilizar SSL está seleccionada y se especifica el certificado correcto, marque solo el puerto SSL. - Asegúrese de que la casilla de verificación Abrir puertos del Agente de red en el firewall de Microsoft Windows esté seleccionada si su infraestructura no usa la configuración centralizada del firewall de Windows y este paquete se usa como paquete de instalación independiente.
- Asegúrese de establecer la configuración correcta en la sección Configurar la conexión mediante el servidor proxy si está utilizando una conexión de servidor proxy.
- Compruebe que la huella digital del certificado del Agente de red del campo Utilizar certificado de servidor coincida con la huella digital del certificado del Servidor de administración del paso 2.
- Si la casilla de verificación Conectar con el Servidor de administración usando una puerta de enlace de conexión está seleccionada, vaya a Avanzado y verifique que se haya especificado la dirección de la puerta de enlace correcta.
Solución 3. Verificar si está instalada la actualización KB3063858 en los dispositivos con sistemas operativos desactualizados
La actualización de seguridad KB3063858 se debe instalar en los sistemas operativos de los dispositivos con la versión 14.2 o posterior del Agente de red. Mitiga los riesgos de seguridad asociados con la interacción entre el Agente de red y el Servidor de administración.
Si la actualización no está instalada en el sistema operativo, el servicio del Agente de red estará en estado Detenido. Si intenta ejecutar los componentes del Agente de red, se bloquearán.
Para solucionar este problema, instale la actualización de seguridad para su sistema operativo y reinicie el dispositivo. El Agente de red se restaurará sin más acciones.
Solución 4. Comprobar si el servicio del Agente de red se inicia y si sus archivos se bloquean
Esta solución es relevante si un objeto del dispositivo tiene la etiqueta Se requiere reiniciar y la tarea de actualización del Agente de red se ha detenido al 32 %.
La situación puede ocurrir si, durante la instalación del Agente de red, sus archivos DLL (por lo general, emcat.dll y em.dll) se han bloqueado sin la posibilidad de sobrescribirlos, por las siguientes razones:
- El complemento MMC del Visor de eventos se abrió en el dispositivo de destino durante la instalación.
- La infraestructura usa los sistemas DLP (Prevención de pérdida de datos) o los agentes del sistema de recopilación y análisis de registros (SIEM, Recopilador de registros).
El bloqueo de estos archivos le impide actualizar el Agente de red a una nueva versión. Se le solicitará que reinicie el sistema operativo sin iniciar el servicio del Agente de red. La tarea de actualización solo continuará cuando se reanude la comunicación con el dispositivo.
Para solucionar este problema, identifique el software de terceros que bloquea los archivos DLL. Para hacerlo, use las siguientes herramientas:
- Supervisión del uso de recursos para Windows
- Explorador de procesos de Microsoft
En el campo de búsqueda, especifique los nombres de los archivos DLL bloqueados del Agente de red.
Si identificó el software, añada los archivos del Agente de red a las exclusiones para ese software o suspenda el software mientras se actualiza el Agente.
Si no identificó el software o esta opción no es adecuada para usted, solicite al usuario que reinicie el sistema operativo cuando instale el Agente de red. Para hacerlo, vaya a Tareas. Elija la opción Instalar aplicación en remoto y busque la tarea Instalar Agente de administración de Kaspersky Security Center. Vaya a Reinicio del sistema operativo y elija el botón de opción Solicitar al usuario una acción.
Solución 5. Comprobar si el Agente de red ya está instalado
Quizás el Agente de red ya esté instalado en el dispositivo de destino, pero esté configurado para funcionar con un servidor diferente o haya perdido la comunicación con el Servidor de administración. Esto puede suceder si el dispositivo no se ha sincronizado con el servidor durante mucho tiempo y no ha logrado obtener un certificado de reserva durante el período de renovación del certificado principal.
Para solucionar este problema, elimine el Agente de red instalado anteriormente e instale la misma versión o una nueva.
Si el dispositivo de destino no usa una pasarela de conexión o un servidor proxy para conectarse al Servidor de administración, puede usar la utilidad klmover para configurar el Agente a fin de que se comunique con el servidor actual sin reinstalar el Agente y luego actualizar el Agente de red a la nueva versión.
Solución 6. Comprobar si se puede acceder al Servidor de administración desde el dispositivo de destino
- Haga lo siguiente:
- Se puede acceder al Servidor de administración desde el dispositivo cliente.
- Las direcciones del Servidor de administración se resuelven correctamente en direcciones IP en el dispositivo cliente.
- Se establecieron las configuraciones correctas para el hardware y la protección de la red, y el sistema operativo del Servidor de administración y del dispositivo de destino.
- No hay errores de conexión en el servidor proxy si se utiliza para conectarse al Servidor de administración.
- La puerta de enlace de conexión está disponible si se usa para conectarse al Servidor de administración.
- Se usa la configuración correcta de los perfiles de conexión en la directiva del Agente de red en el servidor.
Esto es relevante especialmente si el Agente se desconecta del servidor después de la primera sincronización. Para obtener información detallada sobre la conexión del Agente al servidor, consulte este artículo.
- Use la configuración del paquete del instalador de la solución 2 para ejecutar el comando en el dispositivo de destino:
Donde ksc.example.com es el Nombre de dominio completo válido (FQDN) o una dirección IP del Servidor de administración de Kaspersky Security Center si está visible para el dispositivo de destino; 13000 es un puerto de conexión del Agente de red. Este es el puerto SSL si se especifica y se usa un certificado de conexión en el paquete, o el puerto normal si no se usa ningún certificado.
- Analice el resultado del comando y siga las instrucciones de la columna Solución de la tabla.
Qué hacer si el problema continúa
- Asegúrese de que su dispositivo funcione correctamente y de que no haya otros problemas con el hardware, incluida su configuración, la integridad del disco duro o las celdas de RAM.
- Verifique la fecha y hora en su dispositivo.
- Excluya la verificación de la conexión del dispositivo de destino al Servidor de administración y al Agente de red si se usan la inspección profunda de paquetes (DPI) o la tecnología de descifrado y las tecnologías de análisis de tráfico (inspección SSL) como parte del software de protección de terceros.
- Use la utilidad klnagchk para realizar diagnósticos avanzados.
- Si el problema continúa, envíe una solicitud al Servicio de soporte técnico de Kaspersky a través de Kaspersky CompanyAccount.
Describa el problema: especifique qué pasos de las instrucciones ha realizado y añada una salida de consola de los comandos de diagnóstico de este artículo. Adjunte lo siguiente:- Capturas de pantalla del problema y del texto del error que se produce.
- El informe GetSystemInfo con eventos del sistema operativo del dispositivo de destino que no se conecta al Agente de red y del Servidor de administración al que está intentando conectarse.
- El archivo de registro de la utilidad klnagchk
Para obtenerlo, ejecute el comando como administrador desde el directorio de trabajo del Agente de red:
.\klnagchk.exe -logfile c:\klnagchk.log- Registros de instalación del Agente de red.
- Contenido de %Archivos de programa(x86)%\Kaspersky Lab\NetworkAgent\~dumps, si contiene archivos.