Błąd 0x8000ffff podczas instalowania Kaspersky Endpoint Security for Windows

Ostatnia aktualizacja: 06 lutego 2023 ID artykułu: 15565
 
 
 
 

Ten artykuł dotyczy:

  • Kaspersky Endpoint Security 12.0.0 for Windows (wersja 12.0.0.465)
  • Kaspersky Endpoint Security 11.11.0 for Windows (wersja 11.11.0.452)
  • Kaspersky Endpoint Security 11.10.0 for Windows (wersja 11.10.0.399)
  • Kaspersky Endpoint Security 11.9.0 for Windows (wersja 11.9.0.351)
  • Kaspersky Endpoint Security 11.8.0 for Windows (wersja 11.8.0.384)
  • Kaspersky Endpoint Security 11.7.0 for Windows (wersja 11.7.0.669)
  • Kaspersky Endpoint Security 11.6.0 for Windows (wersja 11.6.0.394)
 
 
 
 

Problem

Podczas instalacji sterowników dla Kaspersky Endpoint Security for Windows mogą wystąpić błędy.

Przykłady błędów:

  • InstallDriversDeferred: Nie powiodło się dodanie pliku katalogu. Błąd 0x8000ffff.
    ***
    MSI (s) (14!30) [11:07:22:451]: Produkt: Kaspersky Endpoint Security 10 for Windows – Błąd 27300. Błąd instalacji sterownika driver kl1.sys_X86. Error: -2147418113.
    InstallDriversDeferred: InstallDriversDeferred: finished. Return value 1603.
  • InstallDriversRollback (1b38:20b8) [15:46:19:896]: Failed to execute driver package 'mklif.sys_x64'. Nie powiodło się usuwanie pliku katalogu. Błąd 0x8000ffff.
    ***
    MSI (s) (60!E8) [15:46:19:688]: Produkt: Kaspersky Endpoint Security for Windows – Error 27300. Error installing driver mklif.sys_x64. Error: -2147418113.

Błędy można wykryć w pliku instalacyjnym aplikacji.

Przyczyny

Naruszenie integralności systemu operacyjnego: problemy z usługami kryptograficznymi, bazą danych katalogu dla sterowników CryptoAPI (CAT) i sprawdzenia podpisu katalogu.

Rozwiązywanie problemów

W celu potwierdzenia, że problem dotyczy usług kryptograficznych, możesz wykonać następujące czynności:

  • Sprawdź dziennik systemowy aplikacji na urządzeniu, na którym jest zainstalowana aplikacja. Dziennik może zawierać następujące zdarzenia: „The Cryptographic Services service failed to initialize the Catalog Database. The error was: -2147418113 (0x8000ffff) : Catastrophic failure”.
  • Sprawdź, czy plik %WINDIR%\System32\catroot2\dberr.txt zawiera wiersze z następującym błędem: "encountered JET error -583".
  • Sprawdź, czy plik %WINDIR%\INF\setupapi.dev.log zawiera wiersze z kodem błędu 0x8000ffff. Na przykład: “Error 0x8000ffff: Catastrophic failure”.

Rozwiązanie

Jeśli wykryłeś błędy opisane powyżej:

  1. Rozwiąż problem z systemem operacyjnym lub skontaktuj się z pomocą techniczną systemu Microsoft.
  2. Ponownie zainstaluj aplikację.
 
 
 
 
 
Czy ten artykuł był pomocny?
Co możemy zrobić lepiej?
Dziękujemy za Twoją opinię! Dzięki Tobie możemy ulepszać nasze rozwiązania.
Dziękujemy za Twoją opinię! Dzięki Tobie możemy ulepszać nasze rozwiązania.