Problem podczas aktualizowania Kaspersky Security for Virtualization Light Agent przy użyciu Citrix App Layering i pełnej warstwy użytkownika

 

Kaspersky Security for Virtualization 5.0 | Light Agent

 
 
 

Problem podczas aktualizowania Kaspersky Security for Virtualization Light Agent przy użyciu Citrix App Layering i pełnej warstwy użytkownika

Powrót do sekcji "Rozwiązywanie problemów"
Ostatnia aktualizacja: 07 września 2020 ID artykułu: 15611
 
 
 
 

Artykuł dotyczy Kaspersky Security for Virtualization 5.0 Light Agent.

 
 
 
 

Problem

Jeśli aktualizujesz Kaspersky Security for Virtualization Light Agent do wersji 5.1, która jest używana wraz z Citrix App Layering i pełną warstwą użytkownika, wciąż możesz posiadać foldery, pliki i klucze rejestru z poprzedniej wersji aplikacji na swoim komputerze.

Przyczyna

Zalecenia Citrix odnośnie zainstalowania aplikacji antywirusowej na szablonie z pełną warstwą użytkownika nie zostały zaimplementowane. Pełna warstwa użytkownika rejestruje wszystkie zmiany aktualnie występujące na maszynie wirtualnej.

Rozwiązanie

  1. Szablon z nową wersją aplikacji musi zawierać wielopoziomowy parametr AlwaysOnBoot w kluczu HKLM\SYSTEM\CurrentControlSet\Services\uniflt\. Dodaj następujące foldery jako parametry klucza:
    • %ALLUSERSPROFILE%\KasperskyLab\
    • %ALLUSERSPROFILE%\Kaspersky Lab\
    • %PROGRAMFILES(x86)%\Kaspersky Lab\
    Ten klucz musi znajdować się na warstwie, na której zainstalowano Agenta sieciowego KLNagent i Kaspersky Security for Virtualization Light Agent.
  2. Usuń niepotrzebne dane na warstwach użytkownika przy użyciu Citrix User Layer Repair Utility. Usuń z warstwy użytkownika gałąź rejestru HKEY_LOCALMACHINE\SOFTWARE\Wow6432Node\KasperskyLab\ i następujące foldery:
    • %ALLUSERSPROFILE%\KasperskyLab\
    • %ALLUSERSPROFILE%\Kaspersky Lab\
    • %PROGRAMFILES(x86)%\Kaspersky Lab\

Więcej informacji o instalowaniu aplikacji antywirusowych oraz Citrix User Layer Repair Utility można znaleźć w pomocy Citrix.

 
 
 
 
Czy te informacje były pomocne?
Tak Nie
Dziękujemy
 

 
 

Jak możemy ulepszyć ten artykuł?

Twoja opinia zostanie wykorzystana tylko w celu udoskonalenia zawartości. Jeśli potrzebujesz pomocy, skontaktuj się z działem pomocy technicznej.

Wyślij Wyślij

Dziękujemy za Twoją opinię!

Twoje sugestie pomogą nam ulepszyć ten artykuł.

OK