Błąd „SCRAM authentication requires libpq version 10 or above" podczas instalowania Kaspersky Scan Engine

 

Kaspersky Scan Engine

 
 
 

Błąd „SCRAM authentication requires libpq version 10 or above" podczas instalowania Kaspersky Scan Engine

Ostatnia aktualizacja: 24 listopada 2020 ID artykułu: 15658
 
 
 
 

Problem

Podczas instalowania Kaspersky Scan Engine for Windows może wystąpić błąd „SCRAM authentication requires libpq version 10 or above”.

Przyczyna

Domyślny mechanizm szyfrowania haseł został zmieniony w system zarządzania bazami danych PostgreSQL 13. Początkowy użytkownik postgres, który został utworzony podczas instalacji PostgreSQL, posiada hasło zaszyfrowane przy użyciu algorytmu scram-sha-256. Ten algorytm nie jest obsługiwany przez Kaspersky Scan Engine for Windows.

Rozwiązanie

Zalecane jest użycie PostgreSQL w wersji 11 lub 12. 

Jeśli nie możesz użyć zalecanych wersji, skonfiguruj obsługiwany mechanizm szyfrowania haseł w PostgreSQL. Instrukcje dla następujących scenariuszy instalacji:

Zmiany będą wpływać na cały klaster PostgreSQL i innych aplikacji, które używają klastra.

 
 
 
 
 

Jeśli korzystasz ze scenariusza Instalacja przy użyciu instalatora (Windows)

 
 
 
 
 

Jeśli korzystasz ze scenariusza Instalacja ręczna (Windows)

 
 
 
 
Czy te informacje były pomocne?
Tak Nie
Dziękujemy
 
 
 

 
 

 
 

Jak możemy ulepszyć ten artykuł?

Twoja opinia zostanie wykorzystana tylko w celu udoskonalenia zawartości. Jeśli potrzebujesz pomocy, skontaktuj się z działem pomocy technicznej.

Wyślij Wyślij

Dziękujemy za Twoją opinię!

Twoje sugestie pomogą nam ulepszyć ten artykuł.

OK