Error 0x80004005 „Błąd krytyczny podczas instalacji" występuje po wyłączeniu Windows Defender
Ten artykuł dotyczy:
- Kaspersky Endpoint Security 12.0.0 for Windows (wersja 12.0.0.465)
- Kaspersky Endpoint Security 11.11.0 for Windows (wersja 11.11.0.452)
- Kaspersky Endpoint Security 11.10.0 for Windows (wersja 11.10.0.399)
- Kaspersky Endpoint Security 11.9.0 for Windows (wersja 11.9.0.351)
- Kaspersky Endpoint Security 11.8.0 for Windows (wersja 11.8.0.384)
- Kaspersky Endpoint Security 11.7.0 for Windows (wersja 11.7.0.669)
- Kaspersky Endpoint Security 11.6.0 for Windows (wersja 11.6.0.394)
- Kaspersky Endpoint Security 11.5.0 for Windows (wersja 11.5.0.590)
- Kaspersky Endpoint Security 11.4.0 for Windows (wersja 11.4.0.233)
- Kaspersky Endpoint Security 11.3.0 for Windows (wersja 11.3.0.773)
- Kaspersky Endpoint Security 11.2.0 for Windows (wersja 11.2.0.2254)
Problem
Błąd krytyczny podczas instalacji może wystąpić, gdy instalujesz Kaspersky Endpoint Security.
W raportach z instalacji pojawią się następujące wiersze:
DisableWindowsDefender: Failed to access local group policy. Error 0x80004005.
DisableWindowsDefender: DisableWindowsDefender: finished. Return value 1603.
Przyczyna
Instalator Kaspersky Endpoint Security wywołuje funkcję OpenLocalMachineGPO(GPO_OPEN_LOAD_REGISTRY) i przypisuje jej zasadę grupy lokalnej, co umożliwia wyłączenie Windows Defender i skonfigurowanie ustawień wymaganych do instalacji. Jeśli wyłączenie Windows Defender na hoście docelowym zostanie zablokowane przez zasadę domeny, wystąpi błąd.
Rozwiązanie
- Zastosuj zasadę obiektu zasad grupy (GPO - Group Policy Object) z domyślnymi ustawieniami — Domyślne zasady domeny, gdzie wszystkie elementy Windows Defender posiadają wartość Nie skonfigurowano na hoście docelowym.
- Wymuś zastosowanie zasad grupy na hostach docelowych.
- Uruchom ponownie komputer.
- Spróbuj ponownie zainstalować aplikację.
Co zrobić, jeśli rozwiązanie nie pomogło?
Jeśli powyższe rozwiązanie nie pomogło:
- Tymczasowo przenieś hosta poza domenę Active Directory.
- Zresetuj zasady grupy lokalnej.
- Spróbuj ponownie zainstalować aplikację.
- Po pomyślnej instalacji, przenieś hosta z powrotem do domeny Active Directory.
Jeśli problem nadal występuje, wyślij zgłoszenie do pomocy technicznej Kaspersky za pośrednictwem Kaspersky CompanyAccount. W swoim zgłoszeniu szczegółowo opisz występujący problem. Przed skontaktowaniem się z pomocą techniczną zapoznaj się z przewodnikiem dotyczącym tworzenia zgłoszenia, dostępnym w bazie wiedzy.