Komunikaty „Wykryto problem z weryfikacją certyfikatu” i „Nie można zagwarantować autentyczności domeny, z którą ustanowiono połączenie szyfrowane” podczas próby otwarcia strony internetowej
Ten artykuł dotyczy:
- Kaspersky Anti-Virus
- Kaspersky Internet Security
- Kaspersky Total Security
- Kaspersky Security Cloud
- Kaspersky Small Office Security
Problem
Podczas otwierania strony internetowej pojawia się komunikat ostrzegający, że „Wykryto problem z weryfikacją certyfikatu” lub że „Nie można zagwarantować autentyczności domeny, z którą ustanowiono połączenie szyfrowane”.
Przyczyna
Strona może nie być bezpieczna. Istnieje możliwość, że intruzi mogą wykraść dane Twojego konta i inne informacje osobiste. Nie zalecamy odwiedzania takich stron.
Szczegółowe informacje o tym, co może być przyczyną pojawienia się tego komunikatu, znajdziesz w sekcji poniżej.
Jeśli ostrzeżenie pojawia się nie dla stron internetowych, ale dla aplikacji zainstalowanych na Twoim komputerze, oznacza to, że zostały zmienione domyślne ustawienia skanowania połączeń szyfrowanych. Aby rozwiązać ten problem, przywróć ustawienia domyślne.
Rozwiązanie
Jeśli masz pewność, że dana strona jest bezpieczna (np. jest to oficjalna strona Microsoftu lub oficjalna strona Twojego banku) i odwiedzasz ją regularnie, dodaj ją do wykluczeń. Zobacz instrukcje dla następujących aplikacji:
Jeśli powiadomienie pojawia się na stronie, z której nie korzystasz zbyt często, możesz zezwolić na jej jednorazowe otwarcie. Aby to zrobić:
- W oknie przeglądarki kliknij Pokaż szczegóły → Chcę kontynuować.
- W wyskakującym oknie kliknij Kontynuuj.
Jeśli nie masz pewności, czy dana strona jest bezpieczna, możesz ją sprawdzić za pomocą OpenTip, zanim przejdziesz dalej.
Dlaczego pojawia się komunikat ostrzegawczy
- Certyfikat został wycofany. Na przykład właściciel strony internetowej może zażądać cofnięcia uprawnień, jeśli doszło do włamania na stronę.
- Certyfikat został wydany niezgodnie z przepisami. Po odpowiednim sprawdzeniu certyfikat musi być wydany przez urząd certyfikacji.
- Certyfikaty główne systemu Windows nie są aktualizowane. Na przykład certyfikat DST Root CA X3, na którym opierają się certyfikaty stron internetowych w przeglądarce, wygasł 30 września 2021 roku. Aby sprawdzić, na jakim certyfikacie głównym Windows oparty jest certyfikat witryny, kliknij Wyświetl certyfikat w komunikacie ostrzegawczym, a następnie przejdź do zakładki Ścieżka certyfikacji. Instrukcje dotyczące aktualizacji certyfikatów głównych w systemach Windows 7, 8, 8.1, 10 znajdują się poniżej.
- Łańcuch certyfikatu jest uszkodzony. Certyfikaty są sprawdzane w łańcuchu od certyfikatu samopodpisanego do zaufanego certyfikatu głównego wydanego przez urząd certyfikacji. Certyfikaty znajdujące się pomiędzy nimi są używane do weryfikacji innych certyfikatów w łańcuchu.
Możliwe przyczyny przerwania łańcucha certyfikatów:- Łańcuch składa się z jednego certyfikatu samopodpisanego. Takie certyfikaty nie są weryfikowane przez urząd certyfikacji i nie mogą być godne zaufania.
- Łańcuch nie kończy się na zaufanym certyfikacie głównym.
- Łańcuch zawiera certyfikaty, które nie są przeznaczone do podpisywania innych certyfikatów.
- Certyfikat główny lub pośredni wygasł lub nie rozpoczął się jeszcze jego okres działania. Urząd certyfikacji wydaje certyfikat na określony czas.
- Łańcuch nie może zostać zbudowany.
- Domena podana w certyfikacie nie pasuje do strony internetowej, z którą nawiązano połączenie.
- Certyfikat nie jest przeznaczony do potwierdzania autentyczności węzła. Na przykład, certyfikat jest przeznaczony tylko do szyfrowania połączenia między użytkownikiem a stroną internetową.
- Została naruszona polityka użycia certyfikatu. Polityka certyfikatu jest zbiorem reguł, które określają sposób użycia certyfikatu z uwzględnieniem określonych wymagań bezpieczeństwa. Każdy certyfikat musi odpowiadać co najmniej jednej polityce. Jeśli istnieje kilka polityk, certyfikat musi odpowiadać wszystkim z nich.
- Struktura certyfikatu jest uszkodzona.
- Podczas sprawdzania podpisu certyfikatu wystąpił błąd.
Jak usunąć komunikaty ostrzegawcze o certyfikatach, wyłączając skanowanie połączeń szyfrowanych
Jeżeli nie chcesz, aby aplikacja Kaspersky wyświetlała komunikaty ostrzegawcze o certyfikatach, wyłącz funkcję skanowania połączeń szyfrowanych:
- W oknie głównym aplikacji Kaspersky kliknij
.
- Aby dowiedzieć się, jak otworzyć główne okno aplikacji, zobacz ten artykuł.
- W oknie ustawień przejdź do sekcji Ustawienia sieciowe.
- Zaznacz opcję Nie skanuj połączeń szyfrowanych.
- Przeczytaj komunikat wyświetlony w oknie ostrzeżenia i kliknij Kontynuuj.
- Kliknij Zapisz → Tak.
Jak usunąć komunikaty ostrzegawcze o certyfikatach, dodając stronę internetową do listy wykluczeń w Kaspersky Anti-Virus, Kaspersky Internet Security, Kaspersky Total Security, Kaspersky Security Cloud, Kaspersky Small Office Security
- W oknie głównym aplikacji Kaspersky kliknij
.
- W oknie ustawień przejdź do sekcji Ustawienia sieci i wybierz Zaufane adresy (Zarządzaj wykluczeniami w Kaspersky Internet Security).
- Kliknij Dodaj.
- Podaj adres strony internetowej, która została wyświetlona w komunikacie ostrzegawczym o certyfikacie. Wybierz status Aktywny i kliknij Dodaj.
- Kliknij Zapisz.
- Kliknij Zapisz → Tak.
Strona internetowa zostanie wyłączona z zakresu skanowania połączeń szyfrowanych.
Jak zaktualizować certyfikaty główne w Windows 7, 8, 8.1, 10, 11
- Pobierz plik archiwum CA.zip.
- Wypakuj pliki z tego folderu do folderu C:\CA. Jeśli nie ma takiego folderu, utwórz go.
Upewnij się, że pliki z archiwum znajdują się w tym folderze. - Otwórz wiersz poleceń jako administrator. Instrukcje można znaleźć w tym artykule.
- Uruchom następujące polecenie:
Po uruchomieniu polecenia pojawi się nowy wiersz. Oznacza to, że aktualizacja zakończyła się sukcesem.
- Uruchom ponownie komputer.
Certyfikaty główne zostaną zaktualizowane. Zalecamy także zainstalowanie wszystkich dostępnych aktualizacji dla systemu Windows i przeglądarki, której używasz.
Co zrobić, jeśli wiadomość pojawia się ponownie?
Jeśli dodano już witrynę do listy wykluczeń zakresu skanowania, ale komunikat ostrzegawczy o certyfikacie pojawia się ponownie, uruchom ponownie aplikację Kaspersky lub komputer.
Jeśli ponowne uruchomienie aplikacji nie pomoże, należy skontaktować się z działem obsługi klienta Kaspersky, wybierając temat i wypełniając formularz.