Wyświetlanie komunikatów „Wykryto problem podczas weryfikacji certyfikatu" i „Nie można zagwarantować autentyczności domeny, z którą nawiązywane jest połączenie szyfrowane" podczas próby otwarcia strony internetowej
Ten artykuł dotyczy:
- Kaspersky Anti-Virus
- Kaspersky Internet Security
- Kaspersky Total Security
- Kaspersky Security Cloud
- Kaspersky Small Office Security
Problem
Podczas otwierania strony internetowej wyświetlany jest komunikat informujący, że „Wykryto problem podczas weryfikacji certyfikatu” lub że „Nie można zagwarantować autentyczności domeny, z którą nawiązywane jest połączenie szyfrowane”.
Przyczyna
Strona internetowa może nie być bezpieczna. Istnieje możliwość, że cyberprzestępcy mogą wykraść dane konta i inne informacje osobiste. Nie zalecamy odwiedzania takich stron internetowych.
Więcej informacji o przyczynie wyświetlenia komunikatu można znaleźć w sekcji poniżej.
Jeśli ostrzeżenie pojawi się nie dla stron internetowych, ale dla aplikacji zainstalowanych na Twoim komputerze, to oznacza, że zostały zmienione domyślne ustawienia skanowania połączeń szyfrowanych. Aby rozwiązać problem, przywróć ustawienia domyślne.
Rozwiązanie
Jeśli jesteś pewien, że strona internetowa jest bezpieczna (na przykład, jeśli jest to oficjalna strona Twojego banku) i nie chcesz, żeby aplikacja sprawdzała ją w przyszłości i wyświetlała wiadomości ostrzegające:
- Dodaj stronę internetową, która spowodowała wyświetlenie ostrzeżenia, do listy wykluczeń. Zapoznaj się z poniższymi instrukcjami.
- Alternatywnie wyłącz skanowanie połączeń szyfrowanych. Zapoznaj się z poniższymi instrukcjami.
Nie jest zalecane całkowite wyłączenie skanowania połączeń szyfrowanych, gdyż zmniejszy to poziom ochrony komputera.
Jeśli strona internetowa nie znajduje się wśród tych regularnie odwiedzanych, możesz zezwolić na jej otwarcie dla bieżącej sesji. Następnym razem ponownie pojawi się ostrzeżenie. Poniżej można znaleźć podręcznik dotyczący zezwolenia na jednorazowe otwarcie strony internetowej.
Jeśli powiadomienie pojawi się na stronie internetowej, której często nie otwierasz, możesz zezwolić na jej jednorazowe otwarcie. Zapoznaj się z poniższymi instrukcjami.
Jeśli nie jesteś pewien, czy strona internetowa jest bezpieczna, przed przetworzeniem możesz sprawdzić ją za pomocą OpenTip.
Dlaczego pojawia się wiadomość ostrzegająca?
- Certyfikat utracił ważność. Na przykład, właściciel strony internetowej może zażądać wycofania, jeśli strona została zhakowana.
- Certyfikat został wydany nielegalnie. Certyfikat musi zostać wydany przez urząd certyfikacji po odpowiednim sprawdzeniu.
- Certyfikaty główne systemu Windows nie są aktualizowane (odpowiednie dla systemu Windows 7). Więcej informacji na temat aktualizacji można znaleźć poniżej.
- Łańcuch certyfikatu jest uszkodzony. Certyfikaty są sprawdzane w łańcuchu od certyfikatu z podpisem własnym do zaufanego certyfikatu głównego, wydanego przez urząd certyfikacji. Certyfikaty pomiędzy są używane do weryfikacji innych certyfikatów w łańcuchu.
Możliwe przyczyny złamanego łańcucha certyfikatów:- Łańcuch zawiera jeden certyfikat z podpisem własnym. Takie certyfikaty nie są weryfikowane przez urząd certyfikacji i nie są godne zaufania.
- Łańcuch nie kończy się zaufanym certyfikatem głównym.
- Łańcuch zawiera certyfikaty, które nie służą do podpisywania innych certyfikatów.
- Certyfikat główny lub pośredni wygasł lub nie nadszedł jeszcze jego okres działania. Urzędy certyfikacji wydają certyfikat na określony czas.
- Łańcuch nie może zostać zbudowany.
- Domena określona w certyfikacie nie odpowiada stronie internetowej, z którą nawiązywane jest połączenie.
- Certyfikat nie potwierdza autentyczności węzła. Na przykład, certyfikat jest przeznaczony tylko do szyfrowania połączenia między użytkownikiem a stroną internetową.
- Zasada korzystania z certyfikatu została naruszona. Zasada certyfikatu to zestaw reguł, które definiują użycie certyfikatu z określonymi wymaganiami bezpieczeństwa. Każdy certyfikat musi odpowiadać przynajmniej jednej zasadzie. Jeśli istnieje kilka zasad, certyfikat musi odpowiadać im wszystkim.
- Struktura certyfikatu jest uszkodzona.
- Podczas sprawdzania podpisu certyfikatu wystąpił błąd.
Jak zezwolić na otwarcie strony internetowej?
Kliknij Pokaż szczegóły → Rozumiem zagrożenie i chcę przejść na stronę internetową w oknie przeglądarki.
Alternatywnie, w oknie wyskakującym kliknij Kontynuuj.
Jak usunąć wiadomość z informacją certyfikacie poprzez wyłączenie skanowanie połączeń szyfrowanych?
Jeśli nie chcesz, żeby aplikacja firmy Kaspersky wyświetlała wiadomości informujące o certyfikacie, wyłącz funkcję skanowania połączeń szyfrowanych:
- W oknie głównym aplikacji Kaspersky kliknij
.
- Opis sposobu otwierania okna głównego aplikacji można znaleźć w tym artykule.
- W oknie ustawień przejdź do sekcji Ustawienia sieciowe.
- Wybierz opcję Nie skanuj połączeń szyfrowanych.
- Przeczytaj wiadomość wyświetloną w oknie zawierającym ostrzeżenie, a następnie kliknij Kontynuuj.
- Kliknij Zachowaj → Tak.
Jak usunąć wiadomości z informacją o certyfikacie poprzez dodanie strony internetowej do listy wykluczeń?
- W oknie głównym aplikacji Kaspersky kliknij
.
- W oknie ustawień przejdź do sekcji Ustawienia sieciowe i wybierz Zarządzaj wykluczeniami.
- Kliknij Dodaj.
- Określ adres strony internetowej, który został wyświetlony w wiadomości z informacją o certyfikacie. Wybierz stan Aktywny i kliknij Dodaj.
- Kliknij Zapisz.
- Kliknij Zachowaj → Tak.
Strona internetowa zostanie wykluczona z obszaru skanowania połączeń szyfrowanych.
Jak zaktualizować certyfikaty główne w Windows 7, 8, 8.1, 10
- Pobierz plik archiwum CA.zip.
- Wypakuj pliki z tego folderu do folderu C:\CA. Jeśli nie ma takiego folderu, utwórz go.
- Otwórz wiersz poleceń jako administrator. Instrukcje można znaleźć w tym artykule (wersja angielska).
- Uruchom następujące polecenie:
Po uruchomieniu polecenia pojawi się nowy wiersz. Oznacza to, że aktualizacja zakończyła się sukcesem.
- Uruchom ponownie komputer.
Certyfikaty główne zostaną zaktualizowane. Zalecamy także zainstalowanie wszystkich dostępnych aktualizacji dla systemu Windows i przeglądarki, której używasz.
Co zrobić, jeśli komunikat pojawi się ponownie?
Jeśli już dodałeś stronę internetową do listy wykluczeń z obszaru skanowania, ale wiadomość z informacją o certyfikacie cały czas jest wyświetlana, uruchom aplikację firmy Kaspersky ponownie.
Jeśli ponowne uruchomienie aplikacji nie pomoże, skontaktuj się z pomocą techniczną Kaspersky, wybierając temat i wypełniając formularz.