Windows için Ağ Aracısı ile Yönetim Sunucusu arasındaki bağlantı sorunlarını giderme
Bu makalenin ilgili olduğu uygulamaları ve sürümleri göster
- Kaspersky Security Center 14.2 (sürüm 14.2.0.26967)
- Kaspersky Security Center 14 (sürüm 14.0.0.10902)
Bu makale, size kolaylık sağlamak amacıyla üçüncü bir tarafça sağlanan makine çevirisi yazılımı kullanılarak çevrilmiş ve "olduğu gibi" yayınlanmıştır. İngilizce'den yapılan bu çevirilerin doğruluğu, güvenilirliği veya eksiksizliği konusunda açık veya zımni hiçbir garanti verilmemektedir. Çeviri yazılımının sınırlamaları nedeniyle bazı içerikler doğru şekilde çevrilemeyebilir. İngilizce versiyonu görmek için buraya tıklayabilirsiniz.
Sorun
- Ağ Aracısı uzaktan başarıyla kuruldu, ancak hedef yönetilen aygıt nesnesi Yönetim Sunucusunda görünmedi. Veya nesne belirdi ancak üzerinde Ağ Aracısının kurulu olduğuna dair bir işaret yok.
- Ağ Aracısı ve uygulama paketinin eş zamanlı uzaktan kurulumu %50 oranında çalışır ve Aracının başarıyla yüklendiği mesajının ardından durur. Konsol arayüzündeki Olay Günlüğü, uygulamanın yüklenmediğini gösterir.
- Ağ Aracısının yeni bir sürümü önceki sürümün üzerine yüklendikten sonra yönetilen aygıtla bağlantı kesilir. Bir görev, yönetilen cihazı yeniden başlatmanız gerektiğini belirten bir mesaj görüntüler.
- Klnagchk.exe yardımcı programını kullanarak Yönetim Sunucusuna Ağ Aracısı bağlantısını kontrol etmek bir hatayla sonuçlanır.
- Ağ Aracısının uzaktan kurulumu, “Çalışıyor (%32) (cihaza erişilemiyor)” veya “Kurulum hizmeti bu cihazda çalışıyor” durumunda durur. Lütfen bekleyin...".
Hedef cihazdaki Ağ Aracısı hizmeti çalışmıyor ve herhangi bir bileşeni başlatmaya çalıştığınızda:- Windows uygulama günlüğünde emcat.dl ve em.dll dosyalarıyla ilgili bir olay görüntülenir: “Bilgi 1603. C:\Program Files (x86)\ Kaspersky Lab\NetworkAgent\em.dll dosyası kullanımda tutuluyor. Bu uygulamayı kapatın ve yeniden deneyin."
- Ağ Aracısı, "Hatalı uygulama adı: klnagent.exe, sürüm: 14.2.0.26967, zaman damgası: 0xa0f42d48 Hatalı modül adı: KERNELBASE.dll, sürüm: 6.1.7601.17514, zaman damgası: 0x4ce7bafa <...>" hatasıyla çöküyor .
Neden
- Ağ Aracısı paketinin veya ilkesinin yanlış ayarları.
- Ağ Aracısı hizmeti (klnagent) başarısız oluyor.
- Üçüncü taraf yazılımlar Ağ Aracısı dosyalarını engeller.
- Ağ Aracısı ile Yönetim Sunucusu arasında bağlantı yoktur.
Çözüm
Hedef cihazın işletim sistemini yeniden başlatın ve diskte yeterli alan olduğundan emin olun. Sorunlar devam ederse birkaç çözüm vardır.
Çözüm 1. Atanmamış cihazları arayın
Cihaz, Ağ Aracısı başarıyla yüklendikten sonra yönetilen cihazlar listesinde görünmüyorsa, doğru şekilde bağlanmış olabilir ancak otomatik olarak Yönetilen Cihazlar grubuna taşınmamış olabilir. Bu durumda:
- Yönetim Sunucusuna sağ tıklayın ve Ara öğesini seçin.
- Maskelenen cihaz adının (örn. comp* ) veya IP adresinin ilk harflerini girin ve Şimdi bul öğesine tıklayın.
Cihazı bulursanız Yönetilen Cihazlar grubuna manuel olarak ekleyin.
Cihazı bulamıyorsanız veya bulunan cihazın Yönetim Sunucusuna Son Bağlantı değeri önemli ölçüde güncel değilse, klnagchk.exe yardımcı programını kullanarak hedef cihazdaki Ağ Aracısının durumunu ve bağlantı ayarlarını kontrol edin ve ardından deneyin. Bu makaledeki diğer çözümler.
Çözüm 2. Görev tarafından dağıtılan Ağ Aracısı paketindeki bağlantı ayarlarını kontrol edin
- Kullandığınız Ağ Aracısı paketinin adını öğrenin:
- Görevler'e gidin ve Uygulamayı uzaktan yükle seçeneğini seçin.
- Ayarlar'a tıklayınsol menüde.
Paketin adını Kurulum paketleri bölümünde bulacaksınız.
- Görevi kapatın, Yönetim Sunucusunun özelliklerini açın, Genel'i seçin ve Yönetim Sunucusu sertifikasını görüntüle öğesine tıklayın.
- Yönetim Sunucusunun özelliklerini kapatın. Yönetim Konsolu'nda Gelişmiş → Uzaktan kurulum → Kurulum paketleri seçeneğine gidin.
- Gerekli pakete sağ tıklayın ve özelliklerini açın.
-
Bağlantı'ya
gidin ve aşağıdakileri yapın:
- Sunucu sertifikasını kullan alanındaki Ağ Aracısı sertifika parmak izinin, 2. adımdaki Yönetim Sunucusu sertifika parmak iziyle eşleştiğini kontrol edin.
Sertifikalar eşleşmiyorsa, Ağ Aracısı için sunucudaki %ProgramData%\KasperskyLab\adminkit\1093\cert\klserver.cer klasöründen Yönetim Sunucusu ile aynı sertifikayı seçin. Ayrıntılar için bu makaleye bakabilirsiniz. -
-
Yönetim Sunucusu
alanında Yönetim Sunucusunun doğru adının belirtildiğini ve doğru bağlantı noktalarının ayarlandığını kontrol edin.
SSL Kullan onay kutusu seçiliyse ve doğru sertifika belirtildiyse yalnızca SSL bağlantı noktasını kontrol edin. - Altyapınız merkezi Windows Güvenlik Duvarı yapılandırmasını kullanmıyorsa ve bu paket bağımsız bir kurulum paketi olarak kullanılıyorsa, Microsoft Windows Güvenlik Duvarı'nda Ağ Aracısı bağlantı noktalarını aç onay kutusunun seçili olduğundan emin olun.
- Proxy sunucu bağlantısı kullanıyorsanız Bağlantıyı proxy sunucu aracılığıyla yapılandır bölümünde doğru ayarların yapıldığından emin olun.
- Sunucu sertifikasını kullan alanındaki Ağ Aracısı sertifika parmak izinin, 2. adımdaki Yönetim Sunucusu sertifika parmak iziyle eşleştiğini kontrol edin.
- Yönetim Sunucusuna bağlantı ağ geçidi kullanarak bağlan onay kutusu seçiliyse Gelişmiş'e gidin ve doğru ağ geçidi adresinin belirtildiğini doğrulayın.
Çözüm 3. Güncel olmayan işletim sistemlerine sahip cihazlarda KB3063858 güncellemesini kontrol edin
Ağ Aracısı sürüm 14.2 veya sonraki sürümlere sahip cihazların işletim sistemlerine KB3063858 güvenlik güncelleştirmesinin yüklenmesi gerekir. Ağ Aracısı ile Yönetim Sunucusu arasındaki etkileşimle ilişkili güvenlik risklerini azaltır.
Güncelleme işletim sisteminizde yüklü değilse Ağ Aracısı hizmeti Durduruldu durumunda olacaktır. Ağ Aracısı bileşenlerini çalıştırmayı denerseniz çökeceklerdir.
Bu sorunu düzeltmek için işletim sisteminize yönelik güvenlik güncellemesini yükleyin ve cihazı yeniden başlatın. Ağ Aracısı başka bir işlem yapmadan geri yükleyecektir.
Çözüm 4. Ağ Aracısı hizmetinin başlatılıp başlatılmadığını ve dosyalarının engellenip engellenmediğini kontrol edin
Bu çözüm, bir aygıt nesnesinin Yeniden Başlatma gerekli olarak etiketlenmesi ve Ağ Aracısı güncelleme görevinin %32'de durması durumunda geçerlidir.
Bu durum, Ağ Aracısının kurulumu sırasında DLL dosyalarının (genellikle emcat.dll ve em.dll ) aşağıdaki nedenlerden dolayı üzerine yazılma olasılığı olmadan engellenmesi durumunda ortaya çıkabilir:
- Kurulum sırasında hedef cihazda Olay Görüntüleyicisi MMC ek bileşeni açıldı.
- Altyapı, DLP (Veri Kaybını Önleme) sistemlerini veya log toplama ve analiz sistemi aracılarını (SIEM, Log toplayıcı) kullanır.
Bu dosyaların engellenmesi, Ağ Aracısını yeni bir sürüme yükseltmenizi engeller. Ağ Aracısı hizmetini başlatmadan işletim sistemini yeniden başlatmanız istenecektir. Güncelleme görevi yalnızca cihazla iletişim yeniden başlatıldığında devam edecektir.
Bu sorunu düzeltmek için DLL dosyalarını engelleyen üçüncü taraf yazılımını tanımlayın. Bunu yapmak için araçları kullanın:
- Windows için Kaynak İzleyicisi
-
Microsoft İşlem Gezgini
Arama alanında, Ağ Aracısının engellenen DLL dosyalarının adlarını belirtin.
Yazılımı tanımladıysanız, Ağ Aracısı dosyalarını söz konusu yazılıma ilişkin istisnalara ekleyin veya Aracı güncellenirken yazılımı askıya alın.
Yazılımı tanımlamadıysanız veya bu seçenek sizin için uygun değilse, Ağ Aracısını yüklerken kullanıcıdan işletim sistemini yeniden başlatmasını isteyin. Bunu yapmak için Görevler'e gidin. Uygulamayı uzaktan yükle'yi seçin ve Kaspersky Security Center Yönetim Aracısını Yükle görevini bulun. İşletim sistemini yeniden başlat'a gidin ve Kullanıcıdan eylem yapmasını iste radyo düğmesini seçin.
Çözüm 5. Ağ Aracısının zaten kurulu olup olmadığını kontrol edin
Belki de Ağ Aracısı hedef cihazda zaten yüklüdür ancak farklı bir sunucuyla çalışacak şekilde yapılandırılmıştır veya Yönetim Sunucusu ile iletişim kesilmiş olabilir. Bu, cihazın sunucuyla uzun süre senkronize edilmemesi ve ana sertifika yenileme döneminde yedek sertifika almayı başaramaması durumunda meydana gelebilir.
Bu sorunu düzeltmek için önceden yüklenmiş olan Ağ Aracısını kaldırın ve ardından aynı veya yeni bir sürümü yükleyin.
Hedef cihaz, Yönetim Sunucusuna bağlanmak için bir bağlantı ağ geçidi veya proxy sunucusu kullanmıyorsa, Aracıyı yeniden yüklemeden geçerli sunucuyla iletişim kuracak şekilde Aracıyı yapılandırmak için klmover yardımcı programını kullanabilir ve ardından Ağ Aracısını yeni sürüme yükseltebilirsiniz. versiyon.
Çözüm 6. Yönetim Sunucusuna hedef cihazdan erişilebilir olup olmadığını kontrol edin
- Aşağıdakileri yapın:
- Yönetim Sunucusuna istemci cihazdan erişilebilir.
- Yönetim Sunucusu adresleri, istemci aygıtındaki IP adreslerine doğru şekilde çözümlenir.
- Ağ donanımı ve koruma ile Yönetim Sunucusu ve hedef cihazın işletim sistemi için doğru ayarlar yapılmıştır.
- Yönetim Sunucusuna bağlanmak için kullanılıyorsa proxy sunucu tarafında bağlantı hatası oluşmaz.
- Bağlantı ağ geçidi, Yönetim Sunucusuna bağlanmak için kullanılıyorsa kullanılabilir.
- Sunucudaki Ağ Aracısı ilkesindeki bağlantı profillerinin doğru yapılandırması kullanılır.
Bu, özellikle Aracının ilk senkronizasyondan sonra sunucuyla bağlantısının kesilmesi durumunda geçerlidir. Agent'ı sunucuya bağlamayla ilgili ayrıntılar için bu makaleye bakın.
- Komutu hedef cihazda çalıştırmak için çözüm 2'deki yükleyici paketi ayarlarını kullanın:
Burada ksc.example.com, Tam Nitelikli Etki Alanı Adı (FQDN) veya hedef cihaz için görünürse Kaspersky Security Center Yönetim Sunucusunun IP adresidir; 13000, Ağ Aracısının bağlantı bağlantı noktasıdır. Bu, pakette bir bağlantı sertifikası belirtilip kullanılıyorsa SSL bağlantı noktasıdır veya herhangi bir sertifika kullanılmıyorsa normal bağlantı noktasıdır.
- Komut sonucunu analiz edin ve tablonun Çözüm sütunundaki talimatları izleyin.
Sorun devam ederse ne yapmalı
- Cihazınızın düzgün çalıştığından ve yapılandırması, sabit disk veya RAM hücrelerinin bütünlüğü dahil olmak üzere donanımla ilgili başka bir sorun olmadığından emin olun.
- Cihazınızın tarih ve saatini kontrol edin.
- Üçüncü taraf koruma yazılımının bir parçası olarak Derin Paket Denetimi (DPI) veya şifre çözme teknolojisi ve trafik analizi teknolojileri (SSL denetimi) kullanılıyorsa, hedef cihazın Yönetim Sunucusu ve Ağ Aracısı ile bağlantısının kontrol edilmesini hariç tutun.
- Gelişmiş tanılama gerçekleştirmek için klnagchk yardımcı programını kullanın.
- Sorun hala devam ediyorsa Kaspersky CompanyAccount aracılığıyla Kaspersky Teknik Destek'e bir talep gönderin.
Sorunu açıklayın: Talimatlardan hangi adımları uyguladığınızı belirtin ve bu makaledeki tanılama komutlarının konsol çıktısını ekleyin. Eklemek:- Sorunun ekran görüntüleri ve oluşan hatanın metni.
- Ağ Aracısına bağlanmayan hedef cihazdan ve bağlanmaya çalıştığınız Yönetim Sunucusundan gelen işletim sistemi olaylarını içeren GetSystemInfo raporu.
-
klnagchk
yardımcı programının günlük dosyası
Bunu elde etmek için, Ağ Aracısının çalışma dizininden komutu yönetici olarak çalıştırın:
.\klnagchk.exe -log dosyası c:\klnagchk.log- Ağ Aracısının kurulum günlükleri .
- Dosya içeriyorsa %ProgramFiles(x86)%\ Kaspersky Lab\NetworkAgent\~dökümlerin içeriği.