Kaspersky Total Security 20 System Requirements

 

Kaspersky Total Security 20

 
 
 

Kaspersky Total Security 20 System Requirements

Back to "Installation and Removal"
Latest update: November 06, 2019 ID: 15081
 
 
 
 

General requirements

  • 1500 MB of free disk space.
  • A processor that supports the SSE2 instruction set.
  • Internet connection (for installation and activation, participation in the Kaspersky Security Network, as well as database and program module updates).
  • Microsoft Internet Explorer 8.0 or later 
    • We recommend using Microsoft Internet Explorer 9.0 or later for accessing My Kaspersky.
    • The Anti-Banner component works with restrictions. We recommend using Microsoft Internet Explorer 9.0 or later.
  • Microsoft Windows Installer 4.5 or later
  • Microsoft . NET Framework 4 or later
  • Webcam access protection is only provided for compatible webcam models.
  • On 32-bit operating systems it’s not possible to use a hypervisor for protection.
  • The application cannot be installed on a system or boot drive that uses the FAT32 file system.

Operating system requirements

  • 1 GHz processor or faster.
  • 1 GB of free RAM for 32-bit systems and 2 GB of free RAM for 64-bit systems.

These requirements concern the following operating systems:

  • Microsoft Windows 7 Starter (Service Pack 0 or later)
  • Microsoft Windows 7 Home Basic (Service Pack 0 or later)
  • Microsoft Windows 7 Home Premium (Service Pack 0 or later)
  • Microsoft Windows 7 Professional (Service Pack 0 or later)
  • Microsoft Windows 7 Ultimate (Service Pack 0 or later)
  • Microsoft Windows 8 (Service Pack 0 or later)
  • Microsoft Windows 8 Pro (Service Pack 0 or later)
  • Microsoft Windows 8 Enterprise (Service Pack 0 or later)
  • Microsoft Windows 8.1 (Service Pack 0 and Windows 8.1 Update)
  • Microsoft Windows 8.1 Pro (Service Pack 0 and Windows 8.1 Update)
  • Microsoft Windows 8.1 Enterprise (Service Pack 0 and Windows 8.1 Update)
  • Microsoft Windows 10 Home (versions 507, 1511, 1607, 1703, 1709, 1803, 1809, 1903)
  • Microsoft Windows 10 Enterprise (versions 1507, 1511, 1607, 1703, 1709, 1803, 1809, 1903)
  • Microsoft Windows 10 Pro (versions 1507, 1511, 1607, 1703, 1709, 1803, 1809, 1903)

For more details about using Kaspersky Total Security on Windows 10, see this article.

Supported browsers

  • Browsers that support the Kaspersky Protection extension:
    • Microsoft Internet Explorer 8.0, 9.0, 10.0, 11.0 and later*
      Internet Explorer versions 8.0–11.0 in the new Windows interface style are not supported. Automatic installation of the extension in the browser is not supported on Windows 10.
    • Mozilla™ Firefox™ 52.x–65.x and later*
    • Mozilla Firefox ESR 52.x–60.x and later*
    • Google Chrome 48.x–72.x and later*
  • Browsers that support On-Screen Keyboard, Secure Keyboard Input and encrypted connections scanning:
    • Microsoft Internet Explorer 8.0, 9.0, 10.0, 11.0 and later*
      Internet Explorer versions 8.0–11.0 in the new Windows interface style are not supported.
    • Microsoft Edge (with limitations)
    • Mozilla Firefox 52.x–65.x and later*
    • Mozilla Firefox ESR 52.x–60.5 and later*
    • Google Chrome 48.x-68.x and later*
  • Browsers that support Protected Browser mode:
    • Microsoft Internet Explorer 8.0, 9.0, 10.0, 11.0 and later*
      Internet Explorer versions 8.0–11.0 in the new Windows interface style are not supported.
    • Microsoft Edge (with limitations)
    • Mozilla Firefox 52.x–65.x and later*
    • Mozilla Firefox ESR 52.x–60.x and later*
    • Google Chrome 48.x-72.x and later*
    • Yandex Browser 18.3.1–19.0.3 and later* (with limitations)

*Support of newer versions of these browsers is possible, but not guaranteed in full.

Kaspersky Total Security supports Google Chrome and Mozilla Firefox on both 32-bit and 64-bit operating systems. Internet Explorer 11.0 is not supported in Compatibility Mode on Microsoft Windows 10 RS5 and later.

Requirements for tablets

  • Microsoft Windows 8, Microsoft Windows 8.1 or Microsoft Windows 10
  • Intel Celeron processor at 1.66 GHz or faster
  • 1000 MB of free RAM

Requirements for netbooks

  • Intel Atom processor at 1600 MHz or faster
  • 1024 MB of free RAM
  • 10.1-inch display with a 1024x600 screen resolution
  • Intel GMA 950 or later graphics processor
 
 
 
 
Was this information helpful?
Yes No
Thank you
 

 
 

How can we improve this article?

Your feedback will be used for content improvement purposes only. If you need assistance, please contact technical support.

Submit Submit

Thank you for your feedback!

Your suggestions will help improve this article.

OK