Kaspersky Event Log registers the error “1181/0x80040154 System Error 0x80040154 (Class not registered)”

 

Kaspersky Security Center 10

 
 
 

Kaspersky Event Log registers the error “1181/0x80040154 System Error 0x80040154 (Class not registered)”

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Latest update: October 07, 2019 ID: 12767
 
 
 
 
This article concerns Kaspersky Security Center 10 Maintenance Release 1 (version 10.1.249).
 
 
 
 

Description

On the computer with the Network Agent installed, Kaspersky Endpoint Security 10 for Windows may register the following error in the Kaspersky Event Log when the Firewall manager is opened:

1181/0x80040154 (System Error 0x80040154 (Class not registered)).

Cause:

The error occurs when the Network Agent tries to access the Firewall service which is turned off.

Solution

Go to StartControl PanelWindows Firewall and select the check box Turn off Windows Firewall.

 
 
 
 
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